Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057558 - The customized haproxy_ctld.rb will not take effect after git push unless you restart the haproxy cartridge manually
Summary: The customized haproxy_ctld.rb will not take effect after git push unless you...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1051190
TreeView+ depends on / blocked
 
Reported: 2014-01-24 10:55 UTC by Meng Bo
Modified: 2015-06-29 17:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 19:10:22 UTC


Attachments (Terms of Use)

Description Meng Bo 2014-01-24 10:55:51 UTC
Description of problem:
Create customized haproxy_ctld.rb and git repo .openshift/action_hooks with executable permission. Git push the change to remote.

Since the haproxy cartridge will only reload the configuration but not restart, then the user added haproxy_ctld.rb will never be used unless restart the haproxy manually.

Version-Release number of selected component (if applicable):
devenv_4270

How reproducible:
always

Steps to Reproduce:
1. Create scalable app
2. Add haproxy_ctld.rb to .openshift/action_hooks/ with x permission
3. Git push the change

Actual results:
The customized haproxy_ctld.rb will not take effect till the haproxy restart.

Expected results:
Should trigger the haproxy to restart if the customized haproxy_ctld.rb added.

Additional info:

Comment 1 Brenton Leanhardt 2014-01-31 20:10:12 UTC
Proposed patch: https://github.com/openshift/origin-server/pull/4642

Comment 2 openshift-github-bot 2014-02-03 21:49:38 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/4c8782219b93676ae32edae9f82f94adc30399a8
Bug 1057558 - reload the haproxy_ctld.rb action hook on git push

Comment 3 Meng Bo 2014-02-08 07:05:11 UTC
Checked on devenv_4348, after add the action_hook, the haproxy_ctld will reload the new config, and take effect after git push.

Client output found in the git push log:

remote: HAProxy already running
remote: Action hook haproxy_ctld.rb detected
remote: Action hook haproxy_ctld.rb restarted
remote: HAProxy instance is started


Without the action_hook added, haproxy_ctld will not restart.


Note You need to log in before you can comment on or make changes to this bug.