Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057531 - [RFE] avoid contradictory policies (level 1) for Affinity groups.
Summary: [RFE] avoid contradictory policies (level 1) for Affinity groups.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.0
Assignee: Tomer Saban
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 09:46 UTC by Antoni Segura Puimedon
Modified: 2016-02-10 19:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 11:19:49 UTC
oVirt Team: SLA


Attachments (Terms of Use)
Contradicting affinity policies (deleted)
2014-04-06 11:57 UTC, Doron Fediuck
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 41805 master MERGED core:Added affinity Group collision validation. Never
oVirt gerrit 42398 master MERGED core: Fix NPE in EditAffinityGroupCommandTest Never

Description Antoni Segura Puimedon 2014-01-24 09:46:47 UTC
Description of problem:
If an admistrator adds by mistake a policy that contradicts a previous policy the creation dialog succeeds, the engine events notify of the success, yet the policy never appears on the list of affinity group policies.

Version-Release number of selected component (if applicable): oVirt 3.4 beta


How reproducible:


Steps to Reproduce:
1. Having VM A and VM B in cluster default
2. Add a hard Negative enforcement policy between A and B
3. See that it is listed.
4. Add a hard Positive enforcement policy between A and B

Actual results:
The dialog succeeds, the policy is notified as created but it never shows up.

Expected results:
The dialog does not allow you to create such policy and tell you that you have a conflicting policy (there should be in general a whole class of conflict resolution messages for how soft and hard override as well).

Additional info:

Comment 1 Itamar Heim 2014-01-26 08:10:40 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:18:17 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Gilad Chaplik 2014-04-01 16:51:22 UTC
Propose to move to future or closed won't fix.

Comment 4 Doron Fediuck 2014-04-06 11:57:43 UTC
Created attachment 883247 [details]
Contradicting affinity policies

Comment 5 Doron Fediuck 2014-04-06 11:59:29 UTC
Toni,
Attaching a screenshot to demonstrate it is possible to create contradicting
policies. So the new policy does show up.

The question is if you refer to policy visibility (which as you can see
is supported) or something else?

Comment 6 Sandro Bonazzola 2014-05-08 13:55:31 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 7 Antoni Segura Puimedon 2014-06-09 12:06:29 UTC
It didn't show up for me then, my question is whether this should be allowed at all. It doesn't make much sense to allow creation of conflicting policies, the user should, at least, get a nice warning.

Comment 8 Doron Fediuck 2014-06-09 12:51:55 UTC
We'll handle it for level 1 which means we validate immediate membership
without transitioning.

Comment 10 Doron Fediuck 2015-06-07 08:54:33 UTC
This should be resolved using a can-do-action on affinity group creation / editing.

Comment 11 Max Kovgan 2015-06-28 14:12:14 UTC
ovirt-3.6.0-3 release

Comment 12 Artyom 2015-09-01 10:23:05 UTC
Verified on rhevm-3.6.0-0.12.master.el6.noarch
Error while executing action: Affinity Group collision detected in unified affinity group:
[619070e8-170a-4565-be61-a165fb5a42af, d84baebd-6014-4914-89a1-a80c4cb48b68]
and negative affinity group:
[d84baebd-6014-4914-89a1-a80c4cb48b68, 619070e8-170a-4565-be61-a165fb5a42af]

Comment 13 Sandro Bonazzola 2015-11-04 11:19:49 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.