Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057486 - No error shows when use virsh to connect qemu on rhel 5 xen host
Summary: No error shows when use virsh to connect qemu on rhel 5 xen host
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt
Version: 5.11
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 08:52 UTC by tingting zheng
Modified: 2014-01-24 09:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 09:12:04 UTC


Attachments (Terms of Use)

Description tingting zheng 2014-01-24 08:52:02 UTC
Description
No error shows when use virsh to connect qemu on rhel 5 xen host

Version:
libvirt-0.8.2-29.el5_9.1


How reproducible:
100%

Steps to Reproduce:
1.Boot rhel 5 xen host:
# uname -r
2.6.18-371.el5xen

# rpm -qa |grep qemu
# 

2.Use virsh to connect qemu-kvm,no error shows.
# virsh -c qemu:///system
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # list --all
 Id Name                 State
----------------------------------

3.Try to define guest.
# cat test.xml
……
  <os>
    <type arch='x86_64' machine='xenfv'>hvm</type>
    <loader>/usr/lib/xen/boot/hvmloader</loader>
    <boot dev='hd'/>
  </os>
……

# virsh -c qemu:///system define test.xml
error: Failed to define domain from test.xml
error: unknown OS type hvm

# cat test.xml
……
  <os>
    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
……

# virsh -c qemu:///system define test.xml
error: Failed to define domain from test.xml
error: unknown OS type hvm

Actual results:
As description.

Expected results:
Error shows when use virsh to connect qemu on rhel 5 xen host.

Additional info:

Comment 2 Jiri Denemark 2014-01-24 09:12:04 UTC
There's no reason to show an error when connecting to a qemu driver on a Xen host. The driver is there and working but because you don't have qemu-kvm installed, it is not able to start any domains (look at virsh capabilities to check what kind of guests are supported). The error printed when you try to define any domain is not ideal but it's certainly not important enough to be fixed in RHEL-5.


Note You need to log in before you can comment on or make changes to this bug.