Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057459 - Support execution of externally defined tasks from git
Summary: Support execution of externally defined tasks from git
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.16
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
: 961277 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 07:35 UTC by Nick Coghlan
Modified: 2018-02-06 00:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-17 03:01:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 554844 None CLOSED Document how to bypass the task library 2019-04-01 10:46:01 UTC
Red Hat Bugzilla 729551 None NEW [RFE] enable test branching in git 2019-04-01 10:46:01 UTC

Internal Links: 554844 729551

Description Nick Coghlan 2014-01-24 07:35:51 UTC
Implementation tracking issue for http://beaker-project.org/dev/proposals/external-tasks.html

Concerns/questions still to be addressed:

1. Changing from indicating external tasks by a NULL task reference to using an explicit "external" column in the task library. There will be a default entry used for any tasks that reference an external task without also providing a task name.

2. Whether or not to make the default task entry one that actually retrieves a task via git and runs it in the default harness, rather than requiring the use of a harness other than beah to take advantage of this feature.

Comment 5 Nick Coghlan 2014-03-04 04:46:09 UTC
This can be retested once bug 576304 is VERIFIED.

Comment 6 wangjing 2014-03-05 07:45:23 UTC
verified on beaker-devel(Beaker 0.15.6.git.133.bf56afa)-->pass
steps:
1. set ks_meta="harness=restraint", 
2. set <repo name="beaker-restaint" url="http://file.bos.redhat.com/~bpeck/restraint/el6eso--test/"/>
3. add external task in the job xml and submit the job.
4. check the results according to the doc in comment0:

1.) testing external task in job submitted xml.-->pass
2.) testing external task in job results XML.-->pass
3.) testing Fetching tasks from the Url-->pass

Additional feature:
4.) testing the versions which displayed with the recipe results in Beaker’s web UI and included in the job results XML.-->pass, since beah use the same Api which has been tested in bug 576304.

Comment 7 Dan Callaghan 2014-03-17 03:01:54 UTC
Beaker 0.16.0 has been released.

Comment 8 Dan Callaghan 2014-03-17 03:08:37 UTC
*** Bug 961277 has been marked as a duplicate of this bug. ***

Comment 11 Nick Coghlan 2014-03-25 07:45:22 UTC
For the benefit of those that end up here after trying to use this feature with the default beah harness and finding that it doesn't work, that's because *beah* doesn't support this feature (and likely never will - providing support for this feature by default would likely mean replacing beah with something else as the default harness).

Instead, the external tasks feature is designed to allow alternative harnesses to bypass Beaker's task library if they choose.

One such harness is https://github.com/p3ck/restraint/ (which includes instructions on how to use it to run tests both standalone and in Beaker)


Note You need to log in before you can comment on or make changes to this bug.