Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057442 - InvalidLayoutVariantSpec: '' is not a valid keyboard layout and variant specification
Summary: InvalidLayoutVariantSpec: '' is not a valid keyboard layout and variant speci...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:46a694a075872b62d68236e30bb...
: 1033202 1059050 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 06:30 UTC by Joachim Frieben
Modified: 2014-04-15 22:34 UTC (History)
6 users (show)

Fixed In Version: anaconda-21.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-27 22:16:43 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: anaconda.log (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: environ (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: journalctl (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: lsblk_output (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: nmcli_dev_list (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: os_info (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: program.log (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: storage.log (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: ifcfg.log (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details
File: packaging.log (deleted)
2014-01-24 06:30 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2014-01-24 06:30:04 UTC
Version-Release number of selected component:
anaconda-core-21.18-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 101, in parse_layout_variant
    raise InvalidLayoutVariantSpec(msg)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 854, in set_layouts
    (layout, variant) = parse_layout_variant(layout_variant)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 905, in convert_layout
    self.set_layouts(orig_layouts_variants)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 153, in populate_missing_items
    keyboard.vc_keymap = localed.convert_layout(keyboard.x_layouts[0])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 177, in write_keyboard_config
    populate_missing_items(keyboard)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1521, in execute
    keyboard.write_keyboard_config(self, ROOT_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 70, in doConfiguration
    ksdata.keyboard.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 226, in run
    threading.Thread.run(self, *args, **kwargs)
InvalidLayoutVariantSpec: '' is not a valid keyboard layout and variant specification

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-rawhi rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 nomodeset enforcing=0 BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.13.0-1.fc21.x86_64
other involved packages: python-libs-2.7.5-11.fc21.x86_64
product:        Fedora
release:        Fedora release 21 (Rawhide)
type:           anaconda
version:        rawhide

Comment 1 Joachim Frieben 2014-01-24 06:30:21 UTC
Created attachment 854772 [details]
File: anaconda-tb

Comment 2 Joachim Frieben 2014-01-24 06:30:24 UTC
Created attachment 854773 [details]
File: anaconda.log

Comment 3 Joachim Frieben 2014-01-24 06:30:26 UTC
Created attachment 854774 [details]
File: environ

Comment 4 Joachim Frieben 2014-01-24 06:30:35 UTC
Created attachment 854775 [details]
File: journalctl

Comment 5 Joachim Frieben 2014-01-24 06:30:38 UTC
Created attachment 854776 [details]
File: lsblk_output

Comment 6 Joachim Frieben 2014-01-24 06:30:40 UTC
Created attachment 854777 [details]
File: nmcli_dev_list

Comment 7 Joachim Frieben 2014-01-24 06:30:42 UTC
Created attachment 854778 [details]
File: os_info

Comment 8 Joachim Frieben 2014-01-24 06:30:45 UTC
Created attachment 854779 [details]
File: program.log

Comment 9 Joachim Frieben 2014-01-24 06:30:51 UTC
Created attachment 854780 [details]
File: storage.log

Comment 10 Joachim Frieben 2014-01-24 06:30:53 UTC
Created attachment 854781 [details]
File: ifcfg.log

Comment 11 Joachim Frieben 2014-01-24 06:30:55 UTC
Created attachment 854782 [details]
File: packaging.log

Comment 12 Vratislav Podzimek 2014-01-24 13:04:12 UTC
Please retest and close this bug if it no longer happens.

Comment 13 Clyde E. Kunkel 2014-01-28 04:24:22 UTC
Another user experienced a similar problem:

Happened at end of installation as far as I can see.....

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-rawhi rootfstype=auto ro rd.live.image rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.14.0-0.rc0.git9.1.fc21.x86_64
other involved packages: python-libs-2.7.5-11.fc21.x86_64
package:        anaconda-core-21.18-1.fc21.x86_64
product:        Fedora
reason:         InvalidLayoutVariantSpec: '' is not a valid keyboard layout and variant specification
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 14 Joachim Frieben 2014-01-28 06:19:48 UTC
(In reply to Clyde E. Kunkel from comment #13)
Exact, anaconda crashes after installing the system but -before- creating the initramfs image and -before- completing the system setup thus leaving the user without a new but unbootable system :o(

Comment 15 Vratislav Podzimek 2014-01-29 12:00:14 UTC
*** Bug 1059050 has been marked as a duplicate of this bug. ***

Comment 16 poma 2014-01-29 19:53:13 UTC
anaconda 21.19-1

Installation media:
https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/images/
boot.iso    29-Jan-2014 14:20

sha256sum:
97755c39930734c6071fb5432c08a92b5ec448e9e9058b9b059fa525dd0c4d3c  boot.iso

checkisomd5:
boot.iso:   943e2842c95afe96191f625b82af7bae
Fragment sums: e78e7d968f3fcfa5e5d93487a5c59d9a6f2371a29813e3d37ce8f3e78133
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.

~~~~~~~~~~~~~~~~~~~~~~~~~~~

Tested schemes:
- "Minimal Install" - grub
- "Xfce Desktop" - extlinux

Installation PASSED!

Comment 17 Clyde E. Kunkel 2014-01-29 19:57:33 UTC
Another user experienced a similar problem:

At end of installation--doing final configuration(?).

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --noselinux
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-rawhi rootfstype=auto ro rd.live.image selinux=0 rd.luks=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.14.0-0.rc0.git9.1.fc21.x86_64
other involved packages: python-libs-2.7.5-11.fc21.x86_64
package:        anaconda-core-21.18-1.fc21.x86_64
product:        Fedora
reason:         InvalidLayoutVariantSpec: '' is not a valid keyboard layout and variant specification
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 18 poma 2014-01-29 20:24:39 UTC
(In reply to Clyde E. Kunkel from comment #17)
…
> root=live:CDLABEL=Fedora-Live-Desktop-x86_64-rawhi …> package:        anaconda-core-21.18-1.fc21.x86_64
…

Ver. '21.18-1' is the broken one in this particular case, so people should test with ver. '21.19-1'[1], as I did.

e.g.
http://kojipkgs.fedoraproject.org/work/tasks/8160/6468160/
Fedora-Live-Desktop-x86_64-rawhide-20140129.iso 29-Jan-2014 19:06

If "Live-GNOME" works at all. :)

[1]
http://pkgs.fedoraproject.org/cgit/anaconda.git/commit/?id=1bb62aa722018166702f1180f90217bfe3830a95
http://koji.fedoraproject.org/koji/buildinfo?buildID=494566
Changelog …
…
- Skip empty layout-variant specifications when setting layouts (#1057442) (vpodzime)

Comment 19 Clyde E. Kunkel 2014-01-29 22:22:29 UTC
(In reply to poma from comment #18)
> <snip>> 
> Ver. '21.18-1' is the broken one in this particular case, so people should
> test with ver. '21.19-1'[1], as I did.
> 
> e.g.
> http://kojipkgs.fedoraproject.org/work/tasks/8160/6468160/
> Fedora-Live-Desktop-x86_64-rawhide-20140129.iso 29-Jan-2014 19:06
> 
> If "Live-GNOME" works at all. :)

Thanks.  I thought I had the updated one.

Comment 20 poma 2014-01-30 02:59:38 UTC
;)

anaconda 21.19-1

TEST 2

Installation media:
http://kojipkgs.fedoraproject.org/work/tasks/8189/6468189/
Fedora-Live-Xfce-x86_64-rawhide-20140129.iso    29-Jan-2014 17:38

sha256sum:
51308098aadc7dc0fc87a7b555f60e7dc73d9f13f7183e4c3d4a144bb8a39f0c  Fedora-Live-Xfce-x86_64-rawhide-20140129.iso

checkisomd5:
Fedora-Live-Xfce-x86_64-rawhide-20140129.iso:   3bd3faf47fda0069c366e5e26b63c3c0
Fragment sums: b2bdde3f64d18af7a4b5bb31c26649ae8da78e6e5ef2976a4eff4a172aae
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Tested scheme:
- "Install the live CD to your hard disk(liveinst)" - Standard Partition

Installation PASSED!

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

TEST 3

Installation media:
http://kojipkgs.fedoraproject.org/work/tasks/8160/6468160/
Fedora-Live-Desktop-x86_64-rawhide-20140129.iso    29-Jan-2014 19:06

sha256sum:
ae497c760a1d359e1ce141a95f4a7bd168c1bfc6c2f2e5efbc3d6000d79c8fb5  Fedora-Live-Desktop-x86_64-rawhide-20140129.iso

checkisomd5:
Fedora-Live-Desktop-x86_64-rawhide-20140129.iso:   bccf6e19fe4dcde316b0d77f8acdd5f7
Fragment sums: 81994128f99f6d14e17a2e5ff5db57d4b4a79aae615e4a2c7f4b684c3992
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Tested scheme:
- "Install the live CD to your hard disk(liveinst)" - Standard Partition

Installation PASSED!

Comment 21 Vratislav Podzimek 2014-02-27 09:29:38 UTC
*** Bug 1033202 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.