Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057403 - RFE: As a user I want to download my translated files for a single language
Summary: RFE: As a user I want to download my translated files for a single language
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Usability
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michelle Kim
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
: 1147335 (view as bug list)
Depends On: 1067711
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-24 01:55 UTC by Damian Jansen
Modified: 2015-07-29 02:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 02:48:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1059014 None None None Never

Internal Links: 1059014

Description Damian Jansen 2014-01-24 01:55:34 UTC
Description of problem:

Oddly enough, only a couple of formats (HTML, odt) seem to allow the user to download their files in the translated form.

As a user, if my translated file cannot be downloaded via the WebGUI, I will go to a service that can - not spend an hour trying to find out where the feature is until it becomes apparent that I need to download a secondary application (and learn how to use it) until I can get them back.

Comment 1 Sean Flanigan 2014-01-28 00:59:22 UTC
Can you give an example?  Is it only Properties or XLIFF, or something else?

Comment 2 Damian Jansen 2014-01-29 02:06:51 UTC
Downloading actually can be done, but is a painful process if there are many files.

Changed this to be an RFE.

User should be able to download all of their files, translated, for a given language.

Considerations for file path and tree structure arise - how does one want their project to appear when downloaded? Base level language directories, or directories for languages at each level, or filenames?
e.g.
en_US/mydir/myfile.html or
mydir/en_US/myfile.html or
mydir/myfile_en_US.html

This could be an option, but would be significantly harder to manage.

Related to https://bugzilla.redhat.com/show_bug.cgi?id=1059014

Comment 3 Ding-Yi Chen 2014-03-20 02:18:12 UTC
Is that acceptable these files can be bundle in a zip or tar ball?

If not, Firefox and Chrome would quite likely save files to the default "Downloads" directory instead of the directory structure required by podir and properties projects.

Comment 4 Ding-Yi Chen 2014-03-26 06:32:51 UTC
I think it should depend on 1067711, as the most likely use case is getting the translated files in the original format.

Not quite sure about the dependency between this and bug 1059014, so I put it as see also.

Comment 5 Damian Jansen 2014-09-29 04:08:02 UTC
I realise now that this only works for Podir projects, as specifically implemented by Carlos.  I'd made an RFE in 1147335 requesting support for File, but I'll close that and detail here:
--
As a user, I want to download all my txt, srt, html etc for a web ui supported project.
It's quite unpleasant to not be able to do this, especially for something like a website.

Version-Release number of selected component (if applicable):
3.5.0

Additional info:
Related to https://bugzilla.redhat.com/show_bug.cgi?id=1059014

Comment 6 Damian Jansen 2014-09-29 04:08:56 UTC
*** Bug 1147335 has been marked as a duplicate of this bug. ***

Comment 8 Damian Jansen 2015-07-14 00:20:27 UTC
Reassigned to PM

Comment 9 Zanata Migrator 2015-07-29 02:48:46 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-208


Note You need to log in before you can comment on or make changes to this bug.