Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057380 - Page counter out of sync after failures when using non tx messages and paging
Summary: Page counter out of sync after failures when using non tx messages and paging
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Clebert Suconic
QA Contact: Martin Svehla
Russell Dickenson
URL:
Whiteboard:
: 1055586 (view as bug list)
Depends On: 1057330 1064596
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 23:39 UTC by Clebert Suconic
Modified: 2014-08-06 14:36 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 14:36:39 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker HORNETQ-1309 Major Closed Implement sync of counters for non transactional sends 2015-04-27 09:31:03 UTC
JBoss Issue Tracker JBPAPP-10964 Major Closed Back Port HORNETQ-1309 / BZ1055586 - page counter out of sync after non tx send on paging 2015-04-27 09:31:04 UTC

Description Clebert Suconic 2014-01-23 23:39:30 UTC
Description of problem:
when sending non transactional messages on paging, the counters can get out of sync after failures

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.Send messages non tranasctionally after paging
2. kill the server
3. compare the number of messages against on QueueImpl.getCounter() against the real number of messages

Actual results:

Counter won't match the number of messages.


Expected results:

Exact number of messages

Additional info:

Comment 1 Clebert Suconic 2014-01-24 00:05:34 UTC
*** Bug 1055586 has been marked as a duplicate of this bug. ***

Comment 2 JBoss JIRA Server 2014-01-31 14:05:21 UTC
Clebert Suconic <clebert.suconic@jboss.com> updated the status of jira JBPAPP-10964 to Resolved

Comment 3 JBoss JIRA Server 2014-03-10 15:44:38 UTC
Martin Švehla <msvehla@redhat.com> updated the status of jira JBPAPP-10964 to Closed

Comment 4 Kabir Khan 2014-04-04 14:45:53 UTC
Setting to ON_QA since upgrade should fix this

Comment 5 Martin Svehla 2014-04-28 13:02:15 UTC
Verified with EAP 6.3.0.ER2 / HornetQ 2.3.18.Final


Note You need to log in before you can comment on or make changes to this bug.