Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057264 - WRITE operations in the GlusterFS protocol do not set the size of the write
Summary: WRITE operations in the GlusterFS protocol do not set the size of the write
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.5.0 1057540 1060259
TreeView+ depends on / blocked
 
Reported: 2014-01-23 17:47 UTC by Niels de Vos
Modified: 2014-04-17 13:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1057540 (view as bug list)
Environment:
Last Closed: 2014-04-17 13:15:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2014-01-23 17:47:35 UTC
Description of problem:

Capturing GlusterFS traffic with tcpdump and displaying it in Wireshark 
shows that the size of all WRITEs are 0 bytes. It seems that the 
attribute is not used, and the size is calculated an other way.

Even if the size attribute is not used (yet), it should be set correctly 
to prevent confusing while debugging network traffic with Wireshark or 
other tools.


Version-Release number of selected component (if applicable):
current master

How reproducible:
100%

Steps to Reproduce:
1. tcpdump -s 0 -w /tmp/dump.pcap -i any tcp
2. write something to a volume
3. kill the tcpdump
4. inspect the tcpdump with wireshark/tshark and a filter like this:
       glusterfs.proc == WRITE && glusterfs.size == 0

Actual results:
All WRITE procedures are 0 size.

Expected results:
Correct size of the WRITEs.

Comment 1 Anand Avati 2014-01-23 17:49:37 UTC
REVIEW: http://review.gluster.org/6766 (protocol: pass the size of the data in the WRITE on-wire FOP) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2014-01-23 19:05:15 UTC
REVIEW: http://review.gluster.org/6768 (protocol: pass the size of the data in the WRITE on-wire FOP) posted (#1) for review on release-3.5 by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2014-01-24 09:24:59 UTC
COMMIT: http://review.gluster.org/6768 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit 8a8d5b50dd37732d1fdd56e8fc079ca73513e64f
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Jan 23 18:18:02 2014 +0100

    protocol: pass the size of the data in the WRITE on-wire FOP
    
    Capturing GlusterFS traffic with tcpdump and displaying it in Wireshark
    shows that the size of all WRITEs are 0 bytes. It seems that the
    attribute is not used, and the size is calculated an other way.
    
    Even if the size attribute is not used (yet), it should be set correctly
    to prevent confusing while debugging network traffic with Wireshark or
    other tools.
    
    Note that the on-wire format is not being changed with this patch. The
    size is already part of the structure that is exchanged between the
    client and server.
    
    Change-Id: I4a1729a8e154a6fed4f8baa10ef3009d4df040cf
    Master-Change-Id: I9d67fe17bf203672116dea4948328e2af4004677
    Master-Reviewed-on: http://review.gluster.org/6766
    BUG: 1057264
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6768
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vikhyat Umrao <vumrao@redhat.com>

Comment 4 Anand Avati 2014-01-24 09:27:04 UTC
COMMIT: http://review.gluster.org/6766 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 057e292380cc763ddd4a737d84f406406eaf6d36
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu Jan 23 18:18:02 2014 +0100

    protocol: pass the size of the data in the WRITE on-wire FOP
    
    Capturing GlusterFS traffic with tcpdump and displaying it in Wireshark
    shows that the size of all WRITEs are 0 bytes. It seems that the
    attribute is not used, and the size is calculated an other way.
    
    Even if the size attribute is not used (yet), it should be set correctly
    to prevent confusing while debugging network traffic with Wireshark or
    other tools.
    
    Note that the on-wire format is not being changed with this patch. The
    size is already part of the structure that is exchanged between the
    client and server.
    
    Change-Id: I9d67fe17bf203672116dea4948328e2af4004677
    BUG: 1057264
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6766
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vikhyat Umrao <vumrao@redhat.com>

Comment 5 Anand Avati 2014-01-24 10:28:38 UTC
REVIEW: http://review.gluster.org/6775 (protocol: pass the size of the data in the WRITE on-wire FOP) posted (#1) for review on release-3.4 by Niels de Vos (ndevos@redhat.com)

Comment 6 Anand Avati 2014-02-11 00:04:16 UTC
COMMIT: http://review.gluster.org/6775 committed in release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 3466026bfd1504cbc95a9319147fe67af7bc1ab0
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 24 11:27:43 2014 +0100

    protocol: pass the size of the data in the WRITE on-wire FOP
    
    Capturing GlusterFS traffic with tcpdump and displaying it in Wireshark
    shows that the size of all WRITEs are 0 bytes. It seems that the
    attribute is not used, and the size is calculated an other way.
    
    Even if the size attribute is not used (yet), it should be set correctly
    to prevent confusing while debugging network traffic with Wireshark or
    other tools.
    
    Note that the on-wire format is not being changed with this patch. The
    size is already part of the structure that is exchanged between the
    client and server.
    
    Master-Change-Id: I9d67fe17bf203672116dea4948328e2af4004677
    Master-Reviewed-on: http://review.gluster.org/6766
    Change-Id: I1168461601f725021e4b12a90bbf5afc83fe1d3d
    BUG: 1057264
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6775
    Reviewed-by: Vikhyat Umrao <vumrao@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 7 Niels de Vos 2014-04-17 13:15:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137


Note You need to log in before you can comment on or make changes to this bug.