Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057217 - rebase diskimage builder
Summary: rebase diskimage builder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder
Version: 4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z2
: 4.0
Assignee: Jeff Peeler
QA Contact: Zane Bitter
URL:
Whiteboard:
Depends On:
Blocks: 1057203
TreeView+ depends on / blocked
 
Reported: 2014-01-23 16:16 UTC by Steven Dake
Modified: 2016-04-26 18:42 UTC (History)
7 users (show)

Fixed In Version: diskimage-builder-0.1.5-3.el6ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Rebase package(s) to version: diskimage-builder-0.1.5-3.el6ost Highlights and important bug fixes: This is a rebase which addresses the following: * The ability to be able to boot RHEL 6.5 images. * Documentation on Ramdisk troubleshooting. * Ubuntu element switched to Saucy. * Support added for building openSUSE and Debian images. * Basic support to register to the Red Hat Network (RHN Classic) for packages. * A Red Hat Satellite URL may now be provided as the source for Red Hat packages.
Clone Of:
Environment:
Last Closed: 2014-03-04 20:15:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0213 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-05 01:11:55 UTC
OpenStack gerrit 68675 None None None Never

Description Steven Dake 2014-01-23 16:16:09 UTC
Description of problem:
Rebase disk-image-builder to enable RHEL 6.5 image building

Version-Release number of selected component (if applicable):
latest git - unless there is a release process in place for DIB

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
DIB doesn't build bootable RHEL 6.5 images.

Expected results:
DIB builds bootable RHEL 6.5 images.

Additional info:

Comment 1 Ami Jeain 2014-02-11 10:32:06 UTC
Jeff,

what is the disk-image-create command line that I need to run in order to build the RHEL 6.5 image?
I am able to create the Fedora one.

Comment 2 Jeff Peeler 2014-02-11 16:40:55 UTC
Something like:

disk-image-create -a amd64 rhel vm -o rhel-image.qcow2, with the appropriate environment variables set as defined here:

https://github.com/openstack/diskimage-builder/blob/master/elements/rhel/README.md

Comment 4 Ami Jeain 2014-02-18 16:09:09 UTC
failedQA:
using:
# rpm -qa |grep diskimage
diskimage-builder-0.1.5-2.el6ost.noarch

# export |grep DIB
declare -x DIB_CLOUD_IMAGES="file:///root/images"
declare -x DIB_RHSM_PASSWORD="xxx"
declare -x DIB_RHSM_USER="xxx"
# export | grep BASE
declare -x BASE_IMAGE_FILE="rhel-guest-image-6.5-20140121.0.x86_64.qcow2"

running:
# disk-image-create  rhel vm -o image.qcow2
Building elements: base  rhel vm
Expanded element dependencies to: rpm-distro base rhel cache-url dib-run-parts vm
Building in /tmp/image.nWnAc29g
dib-run-parts Tue Feb 18 18:08:35 IST 2014 Running /tmp/image.nWnAc29g/hooks/root.d/01-ccache
dib-run-parts Tue Feb 18 18:08:35 IST 2014 01-ccache completed
dib-run-parts Tue Feb 18 18:08:35 IST 2014 Running /tmp/image.nWnAc29g/hooks/root.d/10-rhel-cloud-image
Fetching Base Image
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  322M  100  322M    0     0   808M      0 --:--:-- --:--:-- --:--:--  809M
Server returned an unexpected response code. [000]

and no image file is being created

Comment 5 Steven Dake 2014-02-18 16:11:56 UTC
The problem is cache-url does not know how to handle file:// URIs.  Recommend cherrypicking:

commit fde4572764923623da5a208c31a17154fcfc5299
Author: Chris Jones <cmsj@tenshu.net>
Date:   Wed Feb 12 15:11:03 2014 +0000

    Teach cache-url to handle file:// URIs.

    We can now support file:// URIs in source-repositories files and other
    places, by ignoring curl's inability to determine an HTTP status code
    for them.

    Change-Id: Ie226ce05ecb912b23cedc73fd7ba53c0b9c0fe35

Comment 6 Jeff Peeler 2014-02-18 16:23:20 UTC
The above commit has been added to diskimage-builder-0.1.5-3.el6ost.

Comment 13 Zane Bitter 2014-02-28 17:40:46 UTC
Verified using the procedure described in bug 1057203.

Comment 15 errata-xmlrpc 2014-03-04 20:15:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html


Note You need to log in before you can comment on or make changes to this bug.