Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057214 - Unable to add group via RESTAPI
Summary: Unable to add group via RESTAPI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-api
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Juan Hernández
QA Contact: Ondra Machacek
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 16:08 UTC by Ondra Machacek
Modified: 2014-03-31 12:23 UTC (History)
5 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:09 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24205 None None None Never
oVirt gerrit 24336 None None None Never

Description Ondra Machacek 2014-01-23 16:08:22 UTC
Description of problem:
Unable to add group via RESTAPI

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.5.beta1.fc19.noarch
ovirt-engine-restapi-3.4.0-0.5.beta1.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1.
curl -k -X POST -H "Accept: application/xml" -H "Content-Type: application/xml"
    -u admin@internal:password -d
'<group<name>my_domain.com/Users/grupa3</name></group>'  https://ovirt:443/api/groups

Actual results:
<fault>
    <reason>Operation Failed</reason>
    <detail>Entity not found: ADGROUP@my_domain.com:allnames=my_domain.com/Users/grupa3</detail>
</fault>

Expected results:
Group is successfully added.

Additional info:

2014-01-23 17:56:05,391 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--127.0.0.1-8702-5) Operation Failed: Entity not found: ADGROUP@my_domain.com: allnames=my_domain.com/Groups/groupOfUser2

Comment 1 Itamar Heim 2014-01-26 08:10:16 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-02-19 11:56:12 UTC
merged also on 3.4 branch.

Comment 3 Sandro Bonazzola 2014-02-19 12:26:18 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 4 Ondra Machacek 2014-02-25 09:27:27 UTC
Ok in ovirt-engine-restapi-3.4.0-0.11.beta3.el6.noarch

curl -k -X POST -H "Accept: application/xml" -H "Content-Type: application/xml"
 -u $USER -d '<group><name>my_domain.com/Groups/Group75</name></group>'
$URL/api/groups

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<group href="/api/groups/e4cf3a80-b9fb-4b9d-bfba-ac5924788643" id="e4cf3a80-b9fb-4b9d-bfba-ac5924788643">
    <name>my_domain.com/Groups/Group75</name>
    <link href="/api/groups/e4cf3a80-b9fb-4b9d-bfba-ac5924788643/permissions" rel="permissions"/>
    <link href="/api/groups/e4cf3a80-b9fb-4b9d-bfba-ac5924788643/roles" rel="roles"/>
    <link href="/api/groups/e4cf3a80-b9fb-4b9d-bfba-ac5924788643/tags" rel="tags"/>
    <domain href="/api/domains/6272712d-6f70-656e-6c64-61702e726865" id="6272712d-6f70-656e-6c64-61702e726865"/>
    <external_id>146b6ed4fb5f1032868d95616e82060e</external_id>
</group>

Comment 5 Sandro Bonazzola 2014-03-31 12:23:09 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.