Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057212 - OVIRT35 - [RFE] add an explanation tool-tip to the 'Feedback' button (since button behavior may be unexpected/not-understandable in some browsers/clients)
Summary: OVIRT35 - [RFE] add an explanation tool-tip to the 'Feedback' button (since b...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Alexander Wels
QA Contact: Jiri Belka
URL:
Whiteboard: ux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 16:06 UTC by Jiri Belka
Modified: 2016-02-10 19:45 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:37:06 UTC
oVirt Team: UX


Attachments (Terms of Use)
screen-shot: after clicking 'Feedback' (deleted)
2014-01-24 15:48 UTC, Einav Cohen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25703 master MERGED webadmin: feedback tooltip Never

Description Jiri Belka 2014-01-23 16:06:42 UTC
Description of problem:
Clicking on 'Feedback' opens new tab but there's no URL in address bar

Version-Release number of selected component (if applicable):
100%

How reproducible:
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

Steps to Reproduce:
1. click on Feedback in top right corner
2.
3.

Actual results:
new tab but without any url

Expected results:
some page should be opened in new tab

Additional info:

Comment 1 Einav Cohen 2014-01-24 15:48:44 UTC
Created attachment 855057 [details]
screen-shot: after clicking 'Feedback'

Comment 2 Einav Cohen 2014-01-24 15:53:12 UTC
the URL is actually a "mailto:..." URL, and it is supposed to open your default e-mail client. 

I am not sure about it, but I assume that the application doesn't know what type of URL the 'Feedback' will lead to (the URL is brandable/configurable), so just in case - in order to not 'override' the ovirt-engine GUI with the Feedback URL content by mistake - it does the URL "redirection" in the context of a new tab. 

I assume that behavior of opening a new tab is different across different browsers (in my Chrome, for example, it does show the "address" in the address bar, and suggests to open Evolution, which is, apparently, my default e-mail client - see attachment 855057 [details]).

I am not entirely sure what we can do about it. 

@Alex - any improvement suggestions that you can think of?

Comment 3 Alexander Wels 2014-01-24 16:04:17 UTC
Well for ovirt the feedback URL is mailto:... and different browsers will behave differently. The reason the new tab is opened is because the URL can be a regular URL and we don't want clicking the link to close the webadmin.

In theory we could check to see if the URL is a 'mailto' and not open a new tab but the user can configure their browser to have mail go to some web mail like gmail. At which point it will close webadmin again. Or if there is no possible email client, nothing at all will happen, making it appear that the link is broken. Maybe if the URL is a mailto link, we can open up the new tab with some static page that says, attempting to open up your email client? At least that way if the user has no configured email client (as appears to be the case with Jiri, they know we tried something).

Other than that I don't know what we could do to improve the situation.

Comment 4 Einav Cohen 2014-01-24 21:43:02 UTC
creating a page of "attempting to open your local e-mail client..." is a nice idea, however it seems to me a bit of an overkill to create an entire page just for 'mailto' Feedback URLs. 

I just thought of a different idea: Displaying a tool-tip when hovering on the 'Feedback' button. The tool-tip text will be brandable (just like the Feedback text/URL) and if the tool-tip text would be empty - we can display the URL itself in the tool-tip, maybe followed by "(will be opened in a new tab)". 

That way, the user will have a general idea what this button is about to do. 

@Alex - what do you think?

Comment 5 Itamar Heim 2014-01-26 08:11:22 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 6 Alexander Wels 2014-02-03 18:42:29 UTC
I think providing a little more feedback to the user is basically what I was suggesting with the page, but as you said probably a little bit of overkill. Providing a tooltip would be a nice addition and should be easy to accomplish.

Comment 7 Jiri Belka 2014-09-05 12:08:23 UTC
ok, rhevm-webadmin-portal-3.5.0-0.10.master.el6ev.noarch

little BZ1138660 about meaningfulness

Comment 8 Sandro Bonazzola 2014-10-17 12:37:06 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.