Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057203 - Diskimage-builder vm element results in a non-bootable image for RHEL 6.5 cloud image
Summary: Diskimage-builder vm element results in a non-bootable image for RHEL 6.5 clo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder
Version: unspecified
Hardware: Unspecified
OS: Linux
high
urgent
Target Milestone: z2
: 4.0
Assignee: Jeff Peeler
QA Contact: Zane Bitter
URL:
Whiteboard:
Depends On: 1057217
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 15:51 UTC by chris alfonso
Modified: 2016-04-26 13:55 UTC (History)
10 users (show)

Fixed In Version: diskimage-builder-0.1.5-2.el6ost
Doc Type: Bug Fix
Doc Text:
When creating an image using extlinux as the bootloader, the root file system was being improperly mounted. The improper mounting caused a required file system check to fail, which then caused the boot to fail. Now the file system is properly mounted, allowing proper start up.
Clone Of:
Environment:
Last Closed: 2014-03-04 20:15:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0213 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-05 01:11:55 UTC

Description chris alfonso 2014-01-23 15:51:09 UTC
Description of problem:
Using the diskimage-builder vm element to modify the RHEL6.5 image from RHN results in a non-bootable image. The vm element is required to be able to make a VM image bootable and so there is no workaround for customers that want to use diskimage-builder with the latest downloadable RHEL image from RHN.

Version-Release number of selected component (if applicable):


How reproducible:
Set your DIB environment variables appropriately to point to the RHEL 6.5 image that you downloaded to RHN. Then simply use the following command.
disk-image-create --no-tmpfs -a amd64 vm rhel -o RHEL65Test

Register RHEL65Test with glance with the following command.
glance add name=RHEL65Test-x86_64 is_public=true disk_format=qcow2 container_format=bare < RHEL65Test.qcow2

Launch an instance in openstack using the RHEL65Test image. Check the console and see how it doesn't boot.

Comment 2 Derek Higgins 2014-01-23 16:08:40 UTC
Looks like the problem is because the filesystem is being mounted read/write which causes e2fsck to fail to test the image, fix submitted upstream
https://review.openstack.org/#/c/68675/1

Comment 3 chris alfonso 2014-01-27 16:57:49 UTC
This has been merged into http://github.com/openstack/diskimage-builder master and can be pulled into a diskimage-builder package update.

Comment 12 Jeff Peeler 2014-02-19 15:03:48 UTC
This bug was fixed via commit here:
https://github.com/openstack/diskimage-builder/commit/2c8d4b227175a472e4bae20d3ccbc3abe5913f81

Comment 16 Zane Bitter 2014-02-28 17:27:16 UTC
For the record, 'appropriate' environment variables means:

export DIB_CLOUD_IMAGES=file:///path/to/image/dir
export BASE_IMAGE_FILE="rhel-guest-image-6.5-20140121.0.x86_64.qcow2"
export DIB_RHSM_USER="SubscriptionManagerUserName"
export DIB_RHSM_PASSWORD="SubscriptionManagerPassword"

and is documented in part here: https://github.com/openstack/diskimage-builder/blob/master/elements/rhel/README.md

Comment 17 Zane Bitter 2014-02-28 17:38:19 UTC
Verified version diskimage-builder-0.1.5-3.el6ost using the procedure in the Description above, with the environment variables mentioned in Comment #16.

Comment 19 errata-xmlrpc 2014-03-04 20:15:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html


Note You need to log in before you can comment on or make changes to this bug.