Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057193 - Evolution fails to reconnect to Exchange account after suspend/change networks
Summary: Evolution fails to reconnect to Exchange account after suspend/change networks
Keywords:
Status: CLOSED DUPLICATE of bug 1056679
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-ews
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 15:44 UTC by Matthew Saltzman
Modified: 2014-01-23 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 16:49:36 UTC


Attachments (Terms of Use)

Description Matthew Saltzman 2014-01-23 15:44:23 UTC
Description of problem:
After suspending and resuming on another network, Evolution fails to get new messages in an EWS account.  Clicking Send/Receive pops a window up reporting progress getting new messages, but no progress is shown for the EWS account.  Exiting Evolution and restarting solves the problem.

Version-Release number of selected component (if applicable):
evolution-ews-3.10.3-1.fc20.x86_64

How reproducible:
Seems to be always.

Steps to Reproduce:
1. Connect to an EWS account
2. Suspend/resume (may need to change networks)
3. Click Send/Receive

Actual results:
Evolution hangs while updating with no progress on the EWS account.  All other accounts (POP, Gmail) update successfully

Expected results:
EWS account reconnects and updates.

Additional info:
This is a recent regression, possibly as recent as the last update, issued 12/18/13.

Comment 1 Milan Crha 2014-01-23 16:49:36 UTC
Thanks for a bug report. A similar one had been reported only recently, thus I mark this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 1056679 ***


Note You need to log in before you can comment on or make changes to this bug.