Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057162 - [ovirt.log] ERROR - collectd - collectd server not found!
Summary: [ovirt.log] ERROR - collectd - collectd server not found!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: bugs@ovirt.org
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 15:00 UTC by Jiri Belka
Modified: 2016-02-10 19:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:29 UTC
oVirt Team: Node


Attachments (Terms of Use)
/var/log files (deleted)
2014-01-23 15:00 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32478 master MERGED collectd: Better info about failed auto discovery Never

Description Jiri Belka 2014-01-23 15:00:01 UTC
Created attachment 854423 [details]
/var/log files

Description of problem:

There's some ERROR about collectd...

In /var/log/ovirt.log:
...
2014-01-23 13:08:38,952 - INFO - collectd - Attempting to locate remote collectd server...
2014-01-23 13:08:56,983 - ERROR - collectd - collectd server not found!

# egrep -v "^#|^[ \t]*$" /etc/collectd.conf
FQDNLookup   true
LoadPlugin syslog
LoadPlugin cpu
LoadPlugin interface
LoadPlugin load
LoadPlugin memory
Include "/etc/collectd.d"

# /etc/init.d/collectd status
collectd is stopped

# chkconfig --list | grep collect
collectd        0:off   1:off   2:off   3:off   4:off   5:off   6:off

Version-Release number of selected component (if applicable):
# cat /etc/ovirt-node-iso-release 
oVirt Node Hypervisor release 3.0.3 (0.999.201401221941draft.el6)

How reproducible:
100%

Steps to Reproduce:
1. install, check ovirt.log for ERROR about collectd
2.
3.

Actual results:
ERROR but why????

Expected results:
if collectd is optional, skip it. ERROR level is real problem and it seems we don't have real functional problem but something is not used/configured. FATAL|ERROR alerts are those which should highlight interest of administrators...

Additional info:

Comment 1 Itamar Heim 2014-01-26 08:10:32 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:25:41 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Joey Boggs 2014-04-10 16:16:31 UTC
This is an upstream Centos based node not RHEL. collectd does not ship in the RHEL version

From the logs:
Jan 23 13:05:48 localhost kernel: Linux version 2.6.32-431.3.1.el6.x86_64 (mockbuild@c6b10.bsys.dev.centos.org)

Comment 4 Joey Boggs 2014-04-10 16:19:45 UTC
reopening, changing logging level, didnt realize this was filed under ovirt and not rhev-h

Comment 5 Sandro Bonazzola 2014-05-08 13:55:20 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 6 Sandro Bonazzola 2014-10-17 12:40:29 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.