Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057154 - Some properties not persisted during Clone of VM Snapshot
Summary: Some properties not persisted during Clone of VM Snapshot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Martin Betak
QA Contact: Artyom
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 14:30 UTC by Martin Betak
Modified: 2014-12-15 12:46 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:30:52 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23616 None None None Never
oVirt gerrit 23638 None None None Never

Description Martin Betak 2014-01-23 14:30:17 UTC
Description of problem:

The following properties are not properly persisted in when creating a snapshot of a VM and changing them additionally in the dialog:
- allowConsoleReconnect
- customProperties
- runAndPause
- singleQxlPci


How reproducible:
100%


Steps to Reproduce:
1. Have a snapshot for a VM in webadmin
2. Click "clone" 
3. Change some of the above mentioned properties in the dialog
4. Submit
5. Edit the new VM an check changed the properties 

Actual results:

Changes in dialog not reflected


Expected results:

Changes in dialog should be reflected
Additional info:

Comment 1 Artyom 2014-02-17 17:36:41 UTC
Verified on ovirt-engine-3.4.0-0.7.beta2.el6.noarch

Comment 2 Sandro Bonazzola 2014-03-31 12:30:52 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.