Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1057096 - Python binding regression: stream send and sendAll fail
Summary: Python binding regression: stream send and sendAll fail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt-python
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 12:58 UTC by Robie Basak
Modified: 2016-03-20 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-20 16:20:22 UTC


Attachments (Terms of Use)
Fix caller to match callee prototype (deleted)
2014-01-23 12:58 UTC, Robie Basak
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Launchpad 1270588 None None None Never

Description Robie Basak 2014-01-23 12:58:11 UTC
Created attachment 854371 [details]
Fix caller to match callee prototype

I don't see a libvirt-python component, so filing this under libvirt.

Description of problem:


Version-Release number of selected component (if applicable):

git master: de8361627c4f3fa2a1f8dd164ef80c5f0a6a17f6

How reproducible:

100%

Steps to Reproduce:

0. Assuming you start with a volume pool defined called 'default' with no volumes defined in it.

1. virsh vol-create-as default foo 1048576 --format raw

2. In Python:

conn = libvirt.open('qemu:///system')
pool = libvirt_conn.storagePoolLookupByName('default')
vol = pool.storageVolLookupByName('foo')
stream = conn.newStream(0)
vol.upload(stream, 0, 1048576, 0)
stream.send('A' * 65536)

Actual results:

libvirt.libvirtError: virStreamSend() failed

Expected results:

Silent success.

Additional info:

Impact: stops the Python binding from being able to upload volumes to libvirt completely.

Regression caused by commit d40861. Patch attached.

Comment 2 Daniel Berrange 2014-01-23 15:38:47 UTC
Changing component, since bz admins have created libvirt-python now


Note You need to log in before you can comment on or make changes to this bug.