Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056998 - Edit Approve Host popup -> Cluster not updated
Summary: Edit Approve Host popup -> Cluster not updated
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Ravi Nori
QA Contact: bugs@ovirt.org
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 10:15 UTC by Tomas Jelinek
Modified: 2014-03-31 12:24 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:24:43 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine.log (deleted)
2014-03-18 17:02 UTC, Jiri Belka
no flags Details
node logs (deleted)
2014-03-18 17:02 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24875 None MERGED engine, webadmin: Edit Approve Host popup -> Cluster not updated Never
oVirt gerrit 25031 None MERGED engine, webadmin: Edit Approve Host popup -> Cluster not updated Never

Description Tomas Jelinek 2014-01-23 10:15:37 UTC
The host cluster is not updated in the "Edit Approve Host" dialog.

Reproduce:

1: Have two data centers (Default and DC2) and one cluster in each (Default in Default and C2 in DC2).

2: install ovirt node and register it to the engine

3: in web admin right click the added host and select approve

4: in the "Edit Approve Host" screen the Default/Default will be selected. If you change the "Default" DC to DC2, the cluster will still only contain the "Default" cluster

Comment 1 Itamar Heim 2014-01-26 08:10:58 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-03 14:40:35 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 3 Jiri Belka 2014-03-18 17:00:30 UTC
fail, av3.

After changing DC I see following popup:

X Operation Canceled
Error while executing action:

dell-r210ii-04.rhev.lab.eng.brq.redhat.com:

    Host CPU type is not supported in this cluster compatibility version or is not supported at all.

But! If I add host from engine UI, it works OK. Thus only possible explanation is that during switch of the DC in UI, something (Cluster CPU Type) is not loaded correctly.

Comment 4 Jiri Belka 2014-03-18 17:02:10 UTC
Created attachment 876042 [details]
engine.log

Comment 5 Jiri Belka 2014-03-18 17:02:35 UTC
Created attachment 876043 [details]
node logs

Comment 6 Ravi Nori 2014-03-18 17:29:54 UTC
(In reply to Jiri Belka from comment #3)
> fail, av3.
> 
> After changing DC I see following popup:
> 
> X Operation Canceled
> Error while executing action:
> 
> dell-r210ii-04.rhev.lab.eng.brq.redhat.com:
> 
>     Host CPU type is not supported in this cluster compatibility version or
> is not supported at all.
> 
> But! If I add host from engine UI, it works OK. Thus only possible
> explanation is that during switch of the DC in UI, something (Cluster CPU
> Type) is not loaded correctly.

From the logs it looks like the issue is unrelated to this bug.

Comment 7 Sandro Bonazzola 2014-03-31 12:24:43 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.