Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056992 - Foreman will use bridge map even after it is removed from neutron networker parameter
Summary: Foreman will use bridge map even after it is removed from neutron networker ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z4
: 4.0
Assignee: Jiri Stransky
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 10:05 UTC by Ofer Blaut
Modified: 2014-04-02 14:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-02 14:42:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
OVS and puppet output (deleted)
2014-01-23 10:05 UTC, Ofer Blaut
no flags Details
networker node shell output (deleted)
2014-03-31 15:23 UTC, Jiri Stransky
no flags Details

Description Ofer Blaut 2014-01-23 10:05:56 UTC
Created attachment 854275 [details]
OVS and puppet output

Description of problem:

I have remove bridge map and interfaces from foreman neutron networker 

Still the bridge is beginning created.

This is not the case when removing vlan ranges .

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. configure ovs_bridge_uplinks and ovs_bridge_mappings on neutron networker 
2.removed the bridge using ovs-vsctl br-del 
3. run puppet again
4. bridge will be created again 
5. might happen on compute as well ( didn't test )

Actual results:


Expected results:


Additional info:

Comment 1 Mike Orazi 2014-01-27 20:52:46 UTC
I'm not clear on the expected results here.

If I'm reading the report correctly, you set up a Neutron Networker host group  member and watch is install correctly.  Then you are manually removing the bridge, but not changing anything about the Host Group member.  When you re-run puppet with no changes to the parameters, a puppet run restores the bridge as the Host Group and parameters are still describing that as the desired machine state (according to puppet).  

If I read it correctly, I would expect the behavior described (and would in fact expect it to happen automatically if you waited for the puppet agent to check in on its own).

Did I misinterpret what you were attempting and the results?

Comment 2 Ofer Blaut 2014-02-06 06:56:23 UTC
(In reply to Ofer Blaut from comment #0)
> Created attachment 854275 [details]
> OVS and puppet output
> 
> Description of problem:
> 
> I have remove bridge map and interfaces from foreman neutron networker 
> 
> Still the bridge is beginning created.
> 
> This is not the case when removing vlan ranges .
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. configure ovs_bridge_uplinks and ovs_bridge_mappings on neutron networker 
> 2.removed the bridge using ovs-vsctl br-del from host
  3. remove bridge map and interfaces from foreman neutron networker parameters 
> 4. run puppet again
> 5. bridge will be created again 
> 6. might happen on compute as well ( didn't test )
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 3 Ofer Blaut 2014-02-06 06:58:32 UTC
Hi Mike

My mistake in the reproduce steps.

I have removed the bridge-map and interface from both foreman host group parameters  and host it self.

running puppet on the host generated the bridge again.

Ofer

Comment 4 Jiri Stransky 2014-03-31 15:23:46 UTC
Created attachment 880818 [details]
networker node shell output

Comment 5 Jiri Stransky 2014-03-31 15:31:11 UTC
Hi Ofer,

i'm not able to reproduce the error (if i understood the bug report correctly). Please see the attachment above -- networker node shell output, which i think shows correct behavior. I deleted the bridge manually, then reset the ovs_bridge_mappings and ovs_bridge_uplinks to [] and re-run puppet. The bridge didn't get created.

Could you please try to reproduce the error to see if this is still an issue on your setup?

Thanks,

Jirka

Comment 6 Jiri Stransky 2014-03-31 15:42:11 UTC
Here's a link to upstream neutron module that suggests the important part is to set ovs_bridge_mappings to [], and then nothing gets created:

https://github.com/stackforge/puppet-neutron/blob/1cc2b42ceb39b199d96945eb4e6e972e6b32a2b8/manifests/agents/ovs.pp#L36

Comment 9 Jiri Stransky 2014-04-02 14:42:27 UTC
Thanks Ofer for verifying that it's not an issue in current setup.


Note You need to log in before you can comment on or make changes to this bug.