Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056954 - [abrt] Crash in g_settings_backend_dispatch_signal()
Summary: [abrt] Crash in g_settings_backend_dispatch_signal()
Keywords:
Status: CLOSED DUPLICATE of bug 1054365
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL: http://faf-report.itos.redhat.com/rep...
Whiteboard: abrt_hash:5955bce19a775b741ecae27e545...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 09:09 UTC by Michal Toman
Modified: 2018-12-09 17:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 873412
Environment:
Last Closed: 2014-07-07 13:02:26 UTC


Attachments (Terms of Use)

Description Michal Toman 2014-01-23 09:09:20 UTC
+++ This bug was initially created as a clone of Bug #873412 +++

Description of problem:
I attempted to import account and mail information into evolution from an evolution backup archive. 
I tried it several times. This issue doesn't happen very often, but the import of the evolution archive never worked.


Version-Release number of selected component:
evolution-3.6.1-1.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        evolution
crash_function: g_settings_backend_dispatch_signal
kernel:         3.6.5-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 g_settings_backend_dispatch_signal at gsettingsbackend.c:340
: #1 g_settings_backend_path_changed at gsettingsbackend.c:496
: #2 dconf_engine_change_notify at dconfsettingsbackend.c:233
: #3 dconf_engine_watch_established at dconf-engine.c:735
: #5 dconf_gdbus_method_call_done at dconf-gdbus-thread.c:230
: #6 g_simple_async_result_complete at gsimpleasyncresult.c:775
: #7 g_dbus_connection_call_done at gdbusconnection.c:5339
: #8 g_simple_async_result_complete at gsimpleasyncresult.c:775
: #9 complete_in_idle_cb at gsimpleasyncresult.c:787
: #13 g_main_context_iteration at gmain.c:3351

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:22 ---

Created attachment 638877 [details]
File: core_backtrace

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:24 ---

Created attachment 638878 [details]
File: environ

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:27 ---

Created attachment 638879 [details]
File: limits

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:33 ---

Created attachment 638880 [details]
File: backtrace

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:36 ---

Created attachment 638881 [details]
File: cgroup

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:38 ---

Created attachment 638882 [details]
File: executable

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:46 ---

Created attachment 638883 [details]
File: maps

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:51 ---

Created attachment 638884 [details]
File: dso_list

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:56 ---

Created attachment 638885 [details]
File: proc_pid_status

--- Additional comment from w_pirker@gmx.de on 20121105T19:22:59 ---

Created attachment 638886 [details]
File: open_fds

--- Additional comment from w_pirker@gmx.de on 20121105T19:23:01 ---

Created attachment 638887 [details]
File: var_log_messages

--- Additional comment from w_pirker@gmx.de on 20121105T19:42:00 ---

this crash happens very rarely. Out of about maybe twenty import attempts it happened only one time.

--- Additional comment from mcrha@redhat.com on 20121106T10:40:56 ---

Thanks for a bug report. The crashing thread is a DConf dedicated thread, thus I'm moving this there.

--- Additional comment from mcrha@redhat.com on 20130415T09:33:22 ---

*** Bug 951763 has been marked as a duplicate of this bug. ***

--- Additional comment from mcrha@redhat.com on 20130415T09:34:07 ---

The last duplicate is from Fedora 19, thus I'm moving this there.

--- Additional comment from mcrha@redhat.com on 20130606T07:10:29 ---

*** Bug 971183 has been marked as a duplicate of this bug. ***

--- Additional comment from i.gnatenko.brain@gmail.com on 20130612T08:01:22 ---

updated to 3.8.3. started. one of time its crashed.

--- Additional comment from j.heather@surrey.ac.uk on 20130613T06:32:48 ---

Started evolution and it crashed.

reporter:       libreport-2.1.4
backtrace_rating: 3
cmdline:        evolution
crash_function: g_settings_backend_dispatch_signal
executable:     /usr/bin/evolution
kernel:         3.9.4-300.fc19.x86_64
package:        evolution-3.8.3-1.fc19
reason:         Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

--- Additional comment from pbrobinson@gmail.com on 20130618T08:47:54 ---

Seeing this quite a lot when running evo today

--- Additional comment from aaron.lwe@gmail.com on 20130712T07:51:18 ---

Same here, evolution crashed right after started and abrt shows this bug here, evolution-3.8.3-2.fc19.x86_64.

--- Additional comment from craig9384@gmail.com on 20130817T09:54:53 ---

Clicked on Evolution icon  and got a message that it had crashed.  I do not knoe how or why or how to reproduce it.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        evolution
crash_function: g_settings_backend_dispatch_signal
executable:     /usr/bin/evolution
kernel:         3.10.6-200.fc19.x86_64
package:        evolution-3.8.5-2.fc19
reason:         Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            500

--- Additional comment from mcrha@redhat.com on 20130821T06:30:51 ---

*** Bug 999260 has been marked as a duplicate of this bug. ***

--- Additional comment from nalimilan@club.fr on 20131017T09:12:29 ---

Just a me too with 3.8.5-2fc19.

--- Additional comment from nalimilan@club.fr on 20131017T09:19:49 ---

Filed upstream as https://bugzilla.gnome.org/show_bug.cgi?id=710367

Comment 1 Michal Toman 2014-01-23 09:09:22 UTC
The same problem has been detected in Red Hat Enterprise Linux 7. The following packages are affected:

evolution-3.8.5-2.el7.x86_64
evolution-3.8.5-9.el7.x86_64
evolution-3.8.5-13.el7.x86_64

Comment 3 Matthias Clasen 2014-01-27 20:37:35 UTC
upstream indicates that this may be an evolution bug after all

Comment 4 RHEL Product and Program Management 2014-03-22 06:09:59 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 Milan Crha 2014-07-07 13:02:26 UTC

*** This bug has been marked as a duplicate of bug 1054365 ***


Note You need to log in before you can comment on or make changes to this bug.