Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056892 - BR-EX bridge is not created when GRE tenant type is used
Summary: BR-EX bridge is not created when GRE tenant type is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 4.0
Assignee: Jason Guiditta
QA Contact: Ofer Blaut
URL:
Whiteboard:
: 1063231 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 05:37 UTC by Ofer Blaut
Modified: 2014-03-04 20:15 UTC (History)
10 users (show)

Fixed In Version: openstack-foreman-installer-1.0.4-1.el6ost
Doc Type: Bug Fix
Doc Text:
Network interfaces with a full stop (.) in their names are converted by puppet to have an underscore (_) instead. As a result, configuring local_ip would fail if the NIC had a '.' (or possibly a hyphen '-') in its name. This has been fixed by taking the correct name set by the user, and transforming it to the puppet equivalent inside the manifest. As a result, NICs with a full stop in their names are now configured as expected.
Clone Of:
Environment:
Last Closed: 2014-03-04 20:15:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0213 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-03-05 01:11:55 UTC

Description Ofer Blaut 2014-01-23 05:37:54 UTC
Description of problem:

When used foreman to deploy tenant type GRE ( default ) br-ex bridge is not created on neutron networker host

vlan range is being moved into the plugins file

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configure foreman with network parameters for tenant type GRE
2.configure br-ex mapping 
3.check ovs-vsctl on neutron network hosts , it is not created 

Actual results:


Expected results:


Additional info:

Comment 1 Jason Guiditta 2014-01-27 21:54:58 UTC
Ofer, could you provide your networker hostgroup parameter settings so I can better understand what you have tried to do here?  Also, does your nic that you intend to use for the bridge have an ip, or not?

Comment 2 Ofer Blaut 2014-01-28 05:30:31 UTC
Hi Jason

The foreman setup is no longer up.


I have used the default GRE/BR-EX parameters and change the tunnel interface to eth3

I also added bridge map for 

external_network_bridge:br-ex
ovs_vlan_ranges:inter-vlan ext-vlan:195:195
ovs_bridge_mappings: ["ext-vlan:br-ex"]
ovs_bridge_uplinks:["br-ex:eth3.195"]


Thanks

Ofer

Comment 3 Jason Guiditta 2014-01-31 20:24:49 UTC
Judging by the eth3.195 in your uplinks, I am highly suspicious that you hit the same bug reported (and fix pending) here:
https://bugzilla.redhat.com/show_bug.cgi?id=1059417

local_ip is part of the chain of things that get set, and if you look at the related discussion there, you will see that if the interface name has a '.' in it, then the puppet fact name does not match, as '.' is not valid in puppet variable/fact names.  I am going to set this to post and reference the related pull request here:

https://github.com/redhat-openstack/astapor/pull/109

Comment 4 Jason Guiditta 2014-02-03 15:07:43 UTC
Updated pull request merged:

https://github.com/redhat-openstack/astapor/pull/111

Comment 5 Jason Guiditta 2014-02-03 17:55:50 UTC
Enhancement added to make checking a bit better (merged to master):

https://github.com/redhat-openstack/astapor/pull/112

Comment 7 Ofer Blaut 2014-02-20 14:56:28 UTC
Tested using VM running traffic over GRE and also using floating ip to access the web

openstack-foreman-installer-1.0.4-1.el6ost.noarch

Comment 8 Jason Guiditta 2014-03-04 15:02:37 UTC
*** Bug 1063231 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2014-03-04 20:15:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0213.html


Note You need to log in before you can comment on or make changes to this bug.