Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056888 - nfs-ganesha: mount with options are vers=3,proto=udp fails
Summary: nfs-ganesha: mount with options are vers=3,proto=udp fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 05:27 UTC by Saurabh
Modified: 2016-01-19 06:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-07 12:02:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Saurabh 2014-01-23 05:27:06 UTC
Description of problem:

mount with vers=3 and proto=udp fails

[root@rhsauto002 cthon04]# mount -t nfs -o vers=3,proto=udp rhsauto004.lab.eng.blr.redhat.com:/dist-rep /mnt/nfs-test
mount.nfs: mount system call failed

Version-Release number of selected component (if applicable):
nfs-ganesha-2.0.0.1-5.el6rhs.x86_64
glusterfs-3.4.0.57rhs-1.el6rhs.x86_64

How reproducible:
always



Actual results:
mount fails

Expected results:
mount should pass.

Additional info:

Comment 2 Meghana 2014-02-07 11:55:37 UTC
This is a configuration file issue. You have to change the transport protocols in the configuration file.
Transport_Protocols = "TCP,UDP" .
It works fine with this change. This is not a bug. Please close the bug.


Note You need to log in before you can comment on or make changes to this bug.