Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056878 - [RFE][horizon]: Create a volume as a copy of a volume
Summary: [RFE][horizon]: Create a volume as a copy of a volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 5.0 (RHEL 7)
Assignee: Matthias Runge
QA Contact: Amit Ugol
URL: https://blueprints.launchpad.net/hori...
Whiteboard: upstream_milestone_icehouse-3 upstrea...
: 1049983 (view as bug list)
Depends On:
Blocks: 1049983 1082852
TreeView+ depends on / blocked
 
Reported: 2014-01-23 05:08 UTC by RHOS Integration
Modified: 2014-09-08 05:42 UTC (History)
9 users (show)

Fixed In Version: python-django-horizon-2014.1-0.4.b3.fc21
Doc Type: Enhancement
Doc Text:
With this enhancement, you can create a new volume as a copy of an existing volume using the Create Volume option on the Dashboard.
Clone Of:
: 1082852 (view as bug list)
Environment:
Last Closed: 2014-07-08 15:41:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0855 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Dashboard 2014-07-08 19:33:24 UTC

Description RHOS Integration 2014-01-23 05:08:57 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/horizon/+spec/create-volume-from-volume.

Description:

cinder has the option to create a volume as a copy of a volume and we should expose this option via horizon as well.

Specification URL (additional information):

None

Comment 1 Matthias Runge 2014-02-07 08:41:53 UTC
Merged upstream with changeset https://review.openstack.org/#/c/68362/

Comment 2 Matthias Runge 2014-03-18 11:08:08 UTC
or fixed with the corresponding builds from RDO.

Comment 3 Matthias Runge 2014-03-25 09:05:36 UTC
How to test: from the volume tab create a new volume.  As volume source, one now can select an existing volume. This schedules a volume creation via cinder.

Comment 4 Matthias Runge 2014-03-25 09:10:19 UTC
*** Bug 1049983 has been marked as a duplicate of this bug. ***

Comment 6 Amit Ugol 2014-06-12 06:50:11 UTC
Tested with:
openstack-cinder-2014.1-4.el7ost.noarch
python-django-horizon-2014.1-7.el7ost.noarch
volume also takes the image size of the original volume.

Comment 8 errata-xmlrpc 2014-07-08 15:41:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html


Note You need to log in before you can comment on or make changes to this bug.