Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056866 - Error message should be shown when uploading unsupported Open Document Format (e.g. fodt)
Summary: Error message should be shown when uploading unsupported Open Document Format...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Logic
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.3
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 04:53 UTC by Damian Jansen
Modified: 2014-03-20 05:47 UTC (History)
3 users (show)

Fixed In Version: 3.3.0-SNAPSHOT (20140210-0043)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 05:47:07 UTC


Attachments (Terms of Use)
Test fodt file (deleted)
2014-01-23 04:53 UTC, Damian Jansen
no flags Details
Test fodp file (deleted)
2014-01-23 05:09 UTC, Damian Jansen
no flags Details

Description Damian Jansen 2014-01-23 04:53:59 UTC
Created attachment 854183 [details]
Test fodt file

Description of problem:
Cannot upload a .fodt file, responds with
- Invalid document format for test-odt.fodt.
- Transaction failed
There seems to be no indication in the logs to what happened.

Version-Release number of selected component (if applicable):
dev

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in as admin / maintainer, go to a project and project version
2. Click Source Documents, Upload Document
3. Select the attached document and click Upload

Actual results:
- Invalid document format for test-odt.fodt.
- Transaction failed

Expected results:
Upload and save

Additional info:
The same document, saved as an .odt, seems to work fine.

Comment 1 Damian Jansen 2014-01-23 05:09:58 UTC
Created attachment 854189 [details]
Test fodp file

Same goes for .fodp (OpenDoc' Presentation)

Comment 2 Damian Jansen 2014-01-23 05:15:19 UTC
Further testing indicates it applies to all Libreoffice .f*** (Open Document format) files.

Tested using LibreOffice 3.4.5 on RHEL6.4

Comment 3 Sean Flanigan 2014-01-23 05:22:33 UTC
I haven't heard of .fodt before, so I looked it up on wikipedia:

"The OpenDocument format supports the following two ways of document representation:

"As a single XML document - also known as Flat XML or Uncompressed XML Files. Single OpenDocument XML files are not widely used. Filename extensions for a single OpenDocument XML documents are not defined in the OpenDocument technical specification, but commonly used are .xml, .fodt, .fods, ... etc."

https://en.wikipedia.org/wiki/OpenDocument_technical_specification#Document_Representation


So, we're talking about a single XML file instead of the usual "multiple XML files inside a ZIP container".

As if the (compressed) ODT files weren't taking up enough space...

Comment 4 Damian Jansen 2014-01-28 05:04:42 UTC
It appears that it isn't our parsing of the documents that is wrong, but the fact we incorrectly state we support them at all.

Fix: Remove .fod* files from the list of supported filetypes in 
zanata-war/src/main/resources/messages.properties tag jsf.SupportedUploadFormats

Comment 5 Damian Jansen 2014-01-29 05:54:24 UTC
https://github.com/zanata/zanata-server/pull/346

Comment 6 Ding-Yi Chen 2014-02-10 01:02:11 UTC
VERIFIED with Zanata 3.3.0-SNAPSHOT (20140210-0043)

Comment 7 Sean Flanigan 2014-03-20 05:47:07 UTC
Closing VERIFIED bugs for Zanata server 3.3.2.


Note You need to log in before you can comment on or make changes to this bug.