Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056851 - nfs-ganesha: mount path requires that it should start with "/"
Summary: nfs-ganesha: mount path requires that it should start with "/"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha
Version: 2.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Meghana
QA Contact: Saurabh
URL:
Whiteboard:
Depends On:
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2014-01-23 04:35 UTC by Saurabh
Modified: 2016-01-19 06:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
While mounting volume as hostname:volume in NFSv3 mount, the access is denied by server. Workaround: Mount the volume as hostname:/volume in NFSv3, i.e.,prefix the volume name with a "/".
Clone Of:
Environment:
Last Closed: 2014-06-06 17:04:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Saurabh 2014-01-23 04:35:27 UTC
Description of problem:
When we nfs mount the path(in our case it is a volume), we provide the path starting with a slash or without a slash to the mount command, the mount is a success either way.

Problem is with present nfs-ganesha implementation we need to specifically provide the path along with slash in the begining of the path, otherwise the mount operation fails. 

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.57rhs-1.el6rhs.x86_64
nfs-ganesha-2.0.0.1-5.el6rhs.x86_64

How reproducible:
always


Actual results:
Failure result,
[root@rhsauto002 cthon04]# mount -t nfs -o vers=3,proto=tcp rhsauto004.lab.eng.blr.redhat.com:dist-rep /mnt/nfs-test
mount.nfs: access denied by server while mounting rhsauto004.lab.eng.blr.redhat.com:dist-rep

Expected results:
it should work as this,
Pass result,
[root@rhsauto002 cthon04]# mount -t nfs -o vers=3,proto=tcp rhsauto004.lab.eng.blr.redhat.com:/dist-rep /mnt/nfs-test
[root@rhsauto002 cthon04]# 

Additional info:

Comment 2 Soumya Koduri 2014-01-31 11:39:57 UTC
Please test this behaviour using kernel-nfs as well. We suspect that the correct format to be given during mount is server_ip:/volume_path.

Comment 3 Meghana 2014-02-04 11:46:01 UTC
The behaviour of nfs-ganesha is same as the kernel-nfs. 
With kernel-nfs,we see the same error when a similar NFSv3 mount is done.
On the other hand, kernel-nfs supports both ip:/volume and ip:volume kind of  mounts in NFSv4.So does nfs-ganesha.Please close the bug.

Comment 5 Shalaka 2014-02-10 09:16:11 UTC
Please add doc text for this known issue.

Comment 6 Shalaka 2014-02-18 10:45:39 UTC
Please review the edited doc text and sign off.

Comment 7 Meghana 2014-03-17 07:17:12 UTC
The configuration file used to start nfs-ganesha has a "Tag" parameter in the export block. If the mount path doesn't start with a '/' , the tag name is used to address the export entry at mount time. To enable version 3 mounts like mount -t nfs -o vers=3 IP:vol /mnt, the tag name must be the name of the volume.
For example, if the name of the volume is testvol, the tag name should be specified as,

Tag = "testvol";

Comment 8 Soumya Koduri 2014-06-06 17:04:14 UTC
The 'Tag' parameter mentioned in the above notes is currently being used for a different purpose. Also even with the 'Tag' configured same as the volume name, sub-directory mounts will not work if tried to mount using "IP:volume_name" format. 

So we plan to adhere to kernel-nfs behavior in this case and mandate clients to mount using "/" leading character while using Ganesha. This needs to be documented. 

Closing the bug. Please re-open if this needs to be addressed in any of the future release.


Note You need to log in before you can comment on or make changes to this bug.