Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056849 - Incorrect group l10n statistics due to caching missing out update(s)
Summary: Incorrect group l10n statistics due to caching missing out update(s)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 3.3
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
: 3.3
Assignee: Carlos Munoz
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 04:23 UTC by sandeep shedmake
Modified: 2014-03-20 05:47 UTC (History)
5 users (show)

Fixed In Version: 3.3.0-SNAPSHOT (20140217-1515)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 05:47:28 UTC


Attachments (Terms of Use)
Screen shot that demonstrate comment#9 (deleted)
2014-02-13 03:23 UTC, Ding-Yi Chen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1066218 None None None Never

Internal Links: 1066218

Comment 1 sandeep shedmake 2014-01-24 07:20:54 UTC
This bug is also affected by https://bugzilla.redhat.com/show_bug.cgi?id=1057420 , in the sense that project (see attachment 'project_update.png') receives updates, yet ~/version-group/view/ (see attachment 'version_group_view.png') doesn't reflect it.

Comment 4 sandeep shedmake 2014-02-04 07:17:52 UTC
CCing Alex.

Comment 5 Carlos Munoz 2014-02-10 01:57:16 UTC
Fixed calculation errors on the stats and made sure that stats were updated / invalidated when documents are uploaded, deleted, or when copy trans happens.

See:
https://github.com/zanata/zanata-server/pull/361

Comment 6 Ding-Yi Chen 2014-02-13 00:57:13 UTC
Tested with Zanata 3.3.0-SNAPSHOT (20140213-0020)
commit d4627b2ebb39f845d

After you complete translated, the statistics in document list view have not update.

Step to reproduce:
1. Complete translated a project (or find a project that fully translated)
2. Clear a translation
3. Retranslate the cleared translation to make the translation 100% Completed again
4. Click Documents (LOCALE) to go to document list view

Actural:
On the statistics of document list shows 99%(0.12hrs) Words
Clicking the stats by Messages did not change either the percentage,
nor the unit of translation (Message)

Expected:
On the statistics of document list should show 100%(0.0hrs) Words
Clicking the stats by Messages should change both the percentage (if applicable),
and unit of translation (Message)

Reassigned

Comment 7 Damian Jansen 2014-02-13 01:42:47 UTC
The above should be created as a new bug, the original bug here re-evaluated.

Comment 8 Ding-Yi Chen 2014-02-13 01:52:01 UTC
The bug addressed in comment #6 is addressed as Bug 1064628.

Comment 9 Ding-Yi Chen 2014-02-13 03:18:54 UTC
Tested with Zanata 3.3.0-SNAPSHOT (20140213-0020)
commit d4627b2ebb39f845d

In Group View
When the translation is updated, click the locale under Languages column should update the stat of that locale, however, it did not.


Step to reproduce:
1. You need two browser tabs. One showing the group view, the other is in translation editor view, editing one of the documents that belong to project in the group.
2. In translation editor tab, 
   Add a new translation or remove translation to make statistic change.
3. In group view tab, 
   switch the sort under both column "Languages" and <LOCALE> Projects to "word remaining" so you can easily compare.
4. Click at the <Locale> you were editing under the column "Languages" to get the statist of that locale

Actual:
The words under languages column does not equal to the sum of the project remaining words.

Expected:
The words under languages column should equal to the sum of the project remaining words.

Additional:
The value will be corrected after reload the page.

Comment 10 Ding-Yi Chen 2014-02-13 03:23:36 UTC
Created attachment 862620 [details]
Screen shot that demonstrate comment#9

Screen shot that demonstrate comment #9
The total remaining words for French should be 4200, not 4209

Comment 11 Carlos Munoz 2014-02-17 00:40:19 UTC
After reviewing the test scenario, it's determined that this scenario is out of scope for this bug. The issue is that although the cache is correctly updated upon translation, there are parts of the UI that are simply not refreshed when the user clicks to drill down the stats. the problem is partly solved by re-sorting any of the out-of-date panels so the page re-fetches the stats data from the server.

A few suggested approaches for this are:
- Simply update every single section of the UI that has any statistics. This might degrade the user experience by loading too much of the page when clicking around.
- Show a message indicating that some stats might be out of date.

Comment 12 Ding-Yi Chen 2014-02-18 04:38:30 UTC
VERIFIED with Zanata 3.3.0-SNAPSHOT (20140217-1515)

The bug described in comment #9 is now tracked in Bug 1066218

Comment 13 Sean Flanigan 2014-03-20 05:47:28 UTC
Closing VERIFIED bugs for Zanata server 3.3.2.


Note You need to log in before you can comment on or make changes to this bug.