Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056811 - s-ramp.bat ClassDefNotFoundException from jline
Summary: s-ramp.bat ClassDefNotFoundException from jline
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
: 1057598 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 00:23 UTC by kconner
Modified: 2015-08-02 23:46 UTC (History)
5 users (show)

Doc Type: Bug Fix
Doc Text:
When you launch s-ramp.bat on Microsoft Windows, you will encounter an java.lang.NoClassDefFoundError. This exception does not impact on the user. It simply means that the native library failed to load and that it has fallen back to the Java code that handles unsupported screens.
Clone Of:
Environment:
Last Closed: 2014-08-14 16:34:30 UTC
Type: Bug


Attachments (Terms of Use)

Description kconner 2014-01-23 00:23:52 UTC
The native binaries were removed from the s-ramp command line jar at the request of SRT however jline does not handle this cleanly.

When starting up s-ramp.bat the following exception will be seen

[ERROR] Terminal initialization failed; falling back to unsupported
java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32
        at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode(WindowsSupport.java:50)
        at jline.WindowsTerminal.getConsoleMode(WindowsTerminal.java:177)
        at jline.WindowsTerminal.init(WindowsTerminal.java:80)
        at jline.TerminalFactory.create(TerminalFactory.java:101)
        at jline.TerminalFactory.get(TerminalFactory.java:159)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:214)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:206)
        at jline.console.ConsoleReader.<init>(ConsoleReader.java:194)
        at org.overlord.sramp.shell.InteractiveShellCommandReader.open(InteractiveShellCommandReader.java:55)
        at org.overlord.sramp.shell.SrampShell.createCommandReader(SrampShell.java:146)
        at org.overlord.sramp.shell.SrampShell.run(SrampShell.java:90)
        at org.overlord.sramp.shell.SrampShell.main(SrampShell.java:67)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.simontuffs.onejar.Boot.run(Boot.java:340)
        at com.simontuffs.onejar.Boot.main(Boot.java:166)


This exception is harmless as it means that the native library failed to load and that it has fallen back to the java code handling unsupported screens.

This unsupported version also seems to miss some of the escape characters, for example the prompt is now rendered as

←[1m←[31ms-ramp>←[0m

Comment 2 kconner 2014-01-24 14:21:12 UTC
*** Bug 1057598 has been marked as a duplicate of this bug. ***

Comment 3 kconner 2014-08-14 16:34:30 UTC
We have changed the command line dependency to use aesh so this is no longer relevant for 6.1


Note You need to log in before you can comment on or make changes to this bug.