Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056791 - No documentation for --image flag in boot-options.txt
Summary: No documentation for --image flag in boot-options.txt
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: mulhern
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 982164 994488
TreeView+ depends on / blocked
 
Reported: 2014-01-22 22:57 UTC by mulhern
Modified: 2014-06-18 01:53 UTC (History)
1 user (show)

Fixed In Version: anaconda-19.31.56-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 12:19:00 UTC


Attachments (Terms of Use)

Description mulhern 2014-01-22 22:57:59 UTC
Description of problem:

No documentation, either description of format or description of use, for anaconda --image flag.

Version-Release number of selected component (if applicable):

anaconda-21.9

How reproducible:

Always

Steps to Reproduce:

1. grep in docs/boot-options.txt for image and verify that none of the matches
has anything to do with this flag.
2. Similar for installation guide, but this time searched in pdf for --image and only got --image-only option.

Actual results:

No documentation.

Expected results:

Some documentation indicating purpose and accepted format.

Additional info:

Comment 2 mulhern 2014-01-28 15:57:28 UTC
acked.

Comment 3 mulhern 2014-01-28 21:20:08 UTC
But in the wrong place, since it is a command line option, not a boot option.

So, the plan is to augment the help strings in the option parser.

Comment 4 mulhern 2014-01-29 16:04:11 UTC
Posted again.

Comment 5 mulhern 2014-01-29 18:26:53 UTC
Needs a little more revision, specifically separate help text into a separate file as it will be so voluminous.

Comment 6 mulhern 2014-01-30 17:39:26 UTC
Posted again.

Comment 7 mulhern 2014-01-31 13:20:41 UTC
And reviewed favorably. Now I just need qa_ack.

Comment 9 Martin Banas 2014-02-18 08:10:40 UTC
[root@ibm-ps700-01 ~]# anaconda --help
...

  --image=IMAGE_SPEC    Specification of disk image file to be used as
                        installation destination. IMAGE_SPEC must have format
                        <path>[:<name>] where <path> specifies the path of an
                        image file and an optional <name> component is used to
                        identify the disk during installation. <path> must be
                        a local path but it may be relative or absolute. If
                        <name> is not specified, a name is synthesized from
                        the basename of <path>. <name> may not contain a colon
                        or a slash. This option may be used multiple times to
                        specify multiple disk images. It is an error to
                        specify the same <path> twice or to use duplicate
                        names. The --image and --dirinstall options are
                        mutually exclusive.
...

[root@ibm-ps700-01 ~]# rpm -q anaconda
anaconda-19.31.58-1.el7.ppc64



Moving to VERIFIED

Comment 10 Ludek Smid 2014-06-13 12:19:00 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.