Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056748 - ruby ftbfs on rhel7b1
Summary: ruby ftbfs on rhel7b1
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ruby
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vít Ondruch
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 20:20 UTC by Tuomo Soini
Modified: 2018-11-21 12:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 08:06:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
log showing failed test when mock uses tmpfs plugin (deleted)
2014-01-24 18:43 UTC, Tuomo Soini
no flags Details

Description Tuomo Soini 2014-01-22 20:20:46 UTC
mock build of ruby-2.0.0.247-16.el7 always fail on tests.

After serveral tries I managed to get it building with these failing tests removed:

 %check
-DISABLE_TESTS=""
+DISABLE_TESTS="-x test_process.rb -x test_beginendblock.rb -x test_io.rb -x test_imap.rb -x test_cipher.rb"

Comment 2 Vít Ondruch 2014-01-23 08:06:51 UTC
Hi Tuomo,

Thank you for your report. It would be helpful to have log of the errors you are observing, though.

Neverhteless I know for sure that test_imap.rb is failing due to expired certificate [1] and that there are several other cases where the test suite might fail randomly. All of them are reported upstream.

Since last internal build I did passed successfully at 8th of January, I am confident, I can close this issue for now, but don't hesitate to reopen if you have more evidence.


[1] https://bugs.ruby-lang.org/issues/9341

Comment 3 Tuomo Soini 2014-01-24 07:40:13 UTC
Other tests fail randomly, only certificate problem was real issue.

Comment 4 Vít Ondruch 2014-01-24 08:01:01 UTC
(In reply to Tuomo Soini from comment #3)
> Other tests fail randomly, only certificate problem was real issue.

Thank you for confirming.

Comment 5 Tuomo Soini 2014-01-24 18:43:28 UTC
Created attachment 855151 [details]
log showing failed test when mock uses tmpfs plugin

After more testing I found out one test fails every time if mock tmpfs plugin is enabled.

Comment 6 Vít Ondruch 2014-01-27 11:28:59 UTC
I don't read japanese unfortunately, but it seems that something similar was discussed before [1] and it might be Kernel related issue? 



[1] http://blade.nagaokaut.ac.jp/cgi-bin/vframe.rb/ruby/ruby-dev/45703?45593-46734+split-mode-vertical

Comment 7 Tuomo Soini 2014-01-27 11:36:24 UTC
I don't understand japanese either but this looks like /tmp being tmpfs and this same test failing so it's obviously testing something which doesn't work on tmpfs at all.

Comment 8 Vít Ondruch 2014-01-27 11:42:57 UTC
There was reference to Kernel 3.7 and this [1] commit.


[1] http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3d3727cdb07ff17ddc3c551ef8d03d37b60a0372

Comment 9 Tuomo Soini 2014-01-27 12:21:13 UTC
Ok. I was using rhel6 kernel on build system so this is rhel6 kernel bug.

Comment 10 Tuomo Soini 2014-01-28 08:23:44 UTC
Confirmed: that patch on rhel6 kernel fixes the issue.

Comment 11 Vít Ondruch 2014-01-28 08:26:42 UTC
Great! Thank you for confirming.


Note You need to log in before you can comment on or make changes to this bug.