Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056689 - Packstack allinone install swift and nagios by default
Summary: Packstack allinone install swift and nagios by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z4
: 4.0
Assignee: Francesco Vollero
QA Contact: Toure Dunnon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 17:42 UTC by Francesco Vollero
Modified: 2014-05-29 19:57 UTC (History)
8 users (show)

Fixed In Version: openstack-packstack-2013.2.1-0.29.dev1009.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-29 19:57:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0577 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform 4 Bug Fix and Enhancement Advisory 2014-05-29 23:55:40 UTC
OpenStack gerrit 68449 None None None Never
OpenStack gerrit 83352 None None None Never

Description Francesco Vollero 2014-01-22 17:42:47 UTC
Description of problem:

After running packstack --allinone I noticed that swift and nagios are installed even if they should not, according to the default value

Version-Release number of selected component (if applicable):
 current git master

How reproducible:

Reproducible in all the O.S.

Steps to Reproduce:
1. run packstack --allinone

Actual results:

[root@rhel-packstack ~(keystone_admin)]# openstack-status  | grep swift
openstack-swift-proxy:                  active
openstack-swift-account:                active
openstack-swift-container:              active
openstack-swift-object:                 active


Expected results:
openstack-swift-proxy:                  inactive
openstack-swift-account:                inactive
openstack-swift-container:              inactive
openstack-swift-object:                 inactive



Additional info:

Comment 3 Alvaro Lopez Ortega 2014-03-11 19:47:23 UTC
Implemented in master. Backport to Havana required.

Comment 4 Martin Magr 2014-03-27 11:54:45 UTC
For Francesco's patch to not break provisioning manifest one more patch will have to be backported.

Comment 7 Lukas Bezdicka 2014-05-09 13:27:31 UTC
I'm not sure about this, why swift should be disabled? During testing for bug: #1023221 I ran it on rhel6/7 and fedora and it worked fine.

Comment 11 errata-xmlrpc 2014-05-29 19:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0577.html


Note You need to log in before you can comment on or make changes to this bug.