Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056681 - FTBFS of jsr-311 on rhel7b1
Summary: FTBFS of jsr-311 on rhel7b1
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: jsr-311
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ade Lee
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 17:29 UTC by Tuomo Soini
Modified: 2014-01-23 18:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 18:44:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch (deleted)
2014-01-23 18:43 UTC, Nathan Kinder
no flags Details | Diff

Description Tuomo Soini 2014-01-22 17:29:37 UTC
mock build of jsr-311-1.1.1-4.el7 fails with:

[ERROR] Plugin org.apache.maven.plugins:maven-install-plugin:2.3.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for
 org.apache.maven.plugins:maven-install-plugin:jar:2.3.1: The repository system is offline but the artifact org.apache.maven.plugins:maven-install-plugin:p
om:2.3.1 is not available in the local repository. -> [Help 1]


Fix for the issue is adding:

BuildRequires: maven-install-plugin

Comment 2 Nathan Kinder 2014-01-23 18:43:55 UTC
Created attachment 854571 [details]
Patch

This will be fixed in jsr-311-1.1.1-5.el7 with the attached patch.


Note You need to log in before you can comment on or make changes to this bug.