Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056650 - Scan incomplete with server requiring client certificate
Summary: Scan incomplete with server requiring client certificate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sslscan
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Ambroz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 16:01 UTC by Stephan Mueller
Modified: 2014-02-20 06:59 UTC (History)
1 user (show)

Fixed In Version: sslscan-1.10.2-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-17 21:09:24 UTC


Attachments (Terms of Use)

Description Stephan Mueller 2014-01-22 16:01:22 UTC
Description of problem:
When using sslscan against a server that is configured to only allow requests based with a valid client SSL certificate (aka bi-directional authentication), and sslscan cannot offer such a certificate, sslscan will not report any results.

The TLS handshake agrees on the cipher as part of the Client/Server Hello and before the certificate authentication is completed. That means that for scanning a TLS server to see which ciphers are supported, there is NO need for a client certificate and even NO need for a successful TLS session establishment.

sslscan, however, seem to require a successful TLS session establishment before it reports the status on a connection. When reimplementing sslscan with a script as follows, the script will produce the intended output, whereas sslscan does not report status:

ciphers=$(openssl ciphers ALL | sed 's/:/ /g')
protos="ssl2 ssl3 tls1 tls1_1 tls1_2"

for p in $protos
do
        for c in $ciphers
        do
                openssl s_client -connect ${SERVER}:${PORT} -cipher ${c} -${p} > ${SERVER}.${c}.${p}
        done
done

Version-Release number of selected component (if applicable):

version 1.10.1 (and I guess all earlier versions)


How reproducible:
always


Steps to Reproduce:
1. Set up a server with bidirectional authentication requirement
2. sslscan <server>
3. Monitor output of sslscan

Actual results:
no scan results of supported ciphers

Expected results:
scan results with supported ciphers


Additional info:
N/A

Comment 1 Michal Ambroz 2014-01-28 18:19:22 UTC
Submitted upstream as enhancement request:
https://github.com/DinoTools/sslscan/issues/8

Comment 2 Fedora Update System 2014-02-16 16:40:03 UTC
sslscan-1.10.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sslscan-1.10.2-1.fc20

Comment 3 Fedora Update System 2014-02-16 16:40:12 UTC
sslscan-1.10.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sslscan-1.10.2-1.fc19

Comment 4 Fedora Update System 2014-02-16 16:40:20 UTC
sslscan-1.10.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/sslscan-1.10.2-1.el6

Comment 5 Fedora Update System 2014-02-17 21:06:28 UTC
Package sslscan-1.10.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sslscan-1.10.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2655/sslscan-1.10.2-1.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-02-17 21:09:24 UTC
sslscan-1.10.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-02-20 00:42:59 UTC
sslscan-1.10.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-02-20 06:59:17 UTC
sslscan-1.10.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.