Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056649 - [hosted-engine] When hosted engine's console is set to SPICE then it fails
Summary: [hosted-engine] When hosted engine's console is set to SPICE then it fails
Keywords:
Status: CLOSED DUPLICATE of bug 1034634
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.3.1
Assignee: Sandro Bonazzola
QA Contact: Leonid Natapov
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 15:59 UTC by Jiri Belka
Modified: 2014-01-27 10:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-27 10:05:28 UTC
oVirt Team: ---


Attachments (Terms of Use)
vdsm.log (deleted)
2014-01-22 15:59 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-01-22 15:59:21 UTC
Created attachment 853936 [details]
vdsm.log

Description of problem:

When hosted engine's console is set (hosted-engine --deploy) to SPICE then it fails.

...
          You may specify a MAC address for the VM or accept a randomly generated default [00:16:3e:2d:ec:3f]: 
          Please specify the memory size of the VM in MB [Defaults to minimum requirement: 4096]: 
          Please specify the console type you would like to use to connect to the VM (vnc, spice) [vnc]: spice
         
          --== HOSTED ENGINE CONFIGURATION ==--
...
[ INFO  ] Stage: Closing up
[ INFO  ] Creating VM
[ ERROR ] Failed to execute stage 'Closing up': Cannot set temporary password for console connection. The VM may not have been created: please check VDSM logs
[ INFO  ] Stage: Clean up
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

...
Thread-67::ERROR::2014-01-22 16:39:44,898::BindingXMLRPC::1003::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 989, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 240, in vmSetTicket
    return vm.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/API.py", line 592, in setTicket
    return v.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/vm.py", line 4328, in setTicket
    graphics = _domParseStr(self._dom.XMLDesc(0)).childNodes[0]. \
AttributeError: 'NoneType' object has no attribute 'XMLDesc'
Thread-68::DEBUG::2014-01-22 16:39:46,037::BindingXMLRPC::984::vds::(wrapper) client [127.0.0.1]::call vmSetTicket with ('277d29a5-5802-4e2f-9852-ebb6e785262f', '6014arEY', '10800', 'disconnect', {}) {}
Thread-68::ERROR::2014-01-22 16:39:46,037::BindingXMLRPC::1003::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 989, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 240, in vmSetTicket
    return vm.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/API.py", line 592, in setTicket
    return v.setTicket(password, ttl, existingConnAction, params)
  File "/usr/share/vdsm/vm.py", line 4328, in setTicket
    graphics = _domParseStr(self._dom.XMLDesc(0)).childNodes[0]. \
AttributeError: 'NoneType' object has no attribute 'XMLDesc'
Thread-69::DEBUG::2014-01-22 16:39:47,109::BindingXMLRPC::177::vds::(wrapper) client [127.0.0.1]

Version-Release number of selected component (if applicable):
100%

How reproducible:
is32.2 / ovirt-hosted-engine-setup-1.0.0-4.el6ev.noarch

Steps to Reproduce:
1. choose spice for console in `hosted-engine --deploy'
2.
3.

Actual results:
failure

Expected results:
should work

Additional info:
vnc works ok

the attached log contains even my next try with vnc, so please check from the beginning.

Comment 1 Sandro Bonazzola 2014-01-27 10:05:28 UTC
The real error is:

Thread-57::ERROR::2014-01-22 16:39:36,458::vm::2162::vm.Vm::(_startUnderlyingVm) vmId=`277d29a5-5802-4e2f-9852-ebb6e785262f`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 2122, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/vm.py", line 3065, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 76, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2665, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/2
((null):5247): Spice-Warning **: reds.c:3255:reds_init_ssl: Could not load certificates from /etc/pki/libvirt-spice/server-cert.pem
failed to initialize spice server
Thread-57::DEBUG::2014-01-22 16:39:36,469::vm::2615::vm.Vm::(setDownStatus) vmId=`277d29a5-5802-4e2f-9852-ebb6e785262f`::Changed state to Down: internal error process exited while connecting to monitor: char device redirected to /dev/pts/2
((null):5247): Spice-Warning **: reds.c:3255:reds_init_ssl: Could not load certificates from /etc/pki/libvirt-spice/server-cert.pem
failed to initialize spice server

Which is the error reported in bug #1035395 and closed duplicate of bug #1034634.
Closing this as duplicate of bug #1034634 too.

*** This bug has been marked as a duplicate of bug 1034634 ***


Note You need to log in before you can comment on or make changes to this bug.