Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056635 - [AMQP 1.0] Session::nextReceiver() not working
Summary: [AMQP 1.0] Session::nextReceiver() not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: 3.0
: ---
Assignee: Gordon Sim
QA Contact: Irina Boverman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 15:29 UTC by Gordon Sim
Modified: 2014-09-24 15:10 UTC (History)
5 users (show)

Fixed In Version: qpid-cpp-0.22-35
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 15:10:14 UTC


Attachments (Terms of Use)
simple example program using next_receiver (deleted)
2014-03-26 16:53 UTC, Gordon Sim
no flags Details


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5503 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Gordon Sim 2014-01-22 15:29:49 UTC
Description of problem:

The Session::nextReceiver() method always returns false immediately.

Version-Release number of selected component (if applicable):

qpid 0.26

How reproducible:

100%

Steps to Reproduce:
1. Create a program that has one or more receivers created with non-zero capacity
2. call session.nextReceiver(Duration::SECOND*10)
3. send a message to one or more of these receivers

Actual results:

the nextReceiver() call throws NoMessageAvailable exception (or returns false, depending which version is used) immediately

Expected results:

nextReceiver should wait at least for the specified time, and then should return a receiver with a message if one exists

Additional info:

Comment 1 Gordon Sim 2014-01-22 16:04:35 UTC
Fixed upstream: https://svn.apache.org/r1560394

Comment 5 Gordon Sim 2014-03-26 16:53:17 UTC
Created attachment 879125 [details]
simple example program using next_receiver

Comment 7 errata-xmlrpc 2014-09-24 15:10:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.