Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056602 - Missing instructions to enter SESSION_SECRET for console
Summary: Missing instructions to enter SESSION_SECRET for console
Keywords:
Status: CLOSED DUPLICATE of bug 1051804
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Bilhar
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 14:47 UTC by Juergen Hoffmann
Modified: 2015-07-20 00:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 20635, Deployment Guide-2-1.0 Build Date: 14-01-2014 10:00:13 Topic ID: 20580-574965 [Latest]
Last Closed: 2014-01-22 14:59:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Juergen Hoffmann 2014-01-22 14:47:29 UTC
Title: Installing the Management Console

Describe the issue:
The steps are missing instructions as to where to configure the SESSION_SECRET property. It must be configured within /etc/openshift/console.conf

Suggestions for improvement:
Add a section similar to the broker SESSION_SECRET configuration

Here is how I do it for my tutorial on the manual installation of openshift

# session=`echo $(openssl rand -hex 64)` && sed -i -e "$ a\SESSION_SECRET=$session" /etc/openshift/console.conf && echo $session

I echo the session_secret content, so it can be noted down inside an engagement journal.

Additional information:

Comment 2 Alex Dellapenta 2014-01-22 14:59:11 UTC
The reference to the /etc/openshift/console.conf file was accidentally removed from this section in a recent update while another BZ was being worked on. This is being corrected in BZ#1051804. Marking this as a dup of BZ#1051804.

*** This bug has been marked as a duplicate of bug 1051804 ***


Note You need to log in before you can comment on or make changes to this bug.