Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056586 - Clarify CPU labels on frontend
Summary: Clarify CPU labels on frontend
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Artyom
URL:
Whiteboard: virt
: 1028867 (view as bug list)
Depends On: 1012984
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 14:23 UTC by Frantisek Kobzik
Modified: 2016-02-10 19:49 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1012984
Environment:
Last Closed: 2014-10-17 12:34:25 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 20111 None None None Never

Description Frantisek Kobzik 2014-01-22 14:23:07 UTC
+++ This bug was initially created as a clone of Bug #1012984 +++

Description of problem:
The values of host CPU Name and CPU Type on the General sub-tab are obviously switched.
See attached screenshot.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.23.master.el6ev.noarch (is16)

How reproducible:
100%

Steps to Reproduce:
1. Assuming we have host with CPU 'Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz', which belongs to the 'Intel Penryn Family'...
2. In the Hosts main tab, select the host, go to General sub-tab and check the values of CPU Name and CPU Type. 
3.

Actual results:
CPU Name: Intel Penryn Family
CPU Type: Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz

Expected results:
Exactly the opposite, i.e.,
CPU Name: Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz
CPU Type: Intel Penryn Family

Additional info:

This seems to be related only to Webadmin, REST API reports the CPU name correctly:
{{{
<cpu>
  <topology sockets="1" cores="4" threads="1"/>
  <name>Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz</name>
  ...
}}}

Comment 1 Itamar Heim 2014-01-26 08:10:37 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-02-07 11:19:56 UTC
Fixes should be in ovirt-3.4.0-beta2. Assignee please check.

Comment 3 Artyom 2014-02-17 17:19:25 UTC
Checked ovirt-engine-3.4.0-0.7.beta2.el6.noarch
Still the same situation as above.

Comment 4 Piotr Kliczewski 2014-02-20 08:24:21 UTC
*** Bug 1028867 has been marked as a duplicate of this bug. ***

Comment 5 Frantisek Kobzik 2014-02-24 12:21:09 UTC
@Artyom: it's true. It's missing 3.4 backport.
@Michal: should I handle backport or is 3.5 ok? This fix is not really crucial...

Comment 6 Artyom 2014-06-18 12:20:21 UTC
Verified on ovirt-engine-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch

Comment 7 Sandro Bonazzola 2014-10-17 12:34:25 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.