Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056548 - Get rid of calls to gethostbyname()
Summary: Get rid of calls to gethostbyname()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jiří Vymazal
QA Contact: Stefan Dordevic
URL:
Whiteboard:
Depends On: rsyslog-rhel74-rebase
Blocks: 1152157
TreeView+ depends on / blocked
 
Reported: 2014-01-22 12:48 UTC by Tomas Heinrich
Modified: 2017-08-01 09:53 UTC (History)
8 users (show)

Fixed In Version: rsyslog-8.24.0-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1152157 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:53:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2306 normal SHIPPED_LIVE rsyslog bug fix and enhancement update 2017-08-01 12:41:59 UTC
Github rsyslog rsyslog pull 1521 None None None 2017-04-20 08:21:13 UTC

Description Tomas Heinrich 2014-01-22 12:48:43 UTC
Description of problem:
Calls to gethostbyname() should be substituted using getaddrinfo() et al.

Version-Release number of selected component (if applicable):
rsyslog-7.4.7-3.el7

Steps to Reproduce:
Actual results:
$ grep --include "*.[ch]" -ri 'gethostby' rsyslog/
...
./tools/syslogd.c:    hent = gethostbyname((char*)LocalHostName);

Expected results:
The gethostbyname() function is not used.

Additional info:
The relevant part of the code is also of concern to bug #767527.
Relevant upstream commit:
http://git.adiscon.com/?p=rsyslog.git;a=commitdiff;h=209a6d8e

Comment 10 Jiří Vymazal 2017-04-10 08:12:59 UTC
Ok, checked again, this will need a patch

Comment 17 errata-xmlrpc 2017-08-01 09:53:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2306


Note You need to log in before you can comment on or make changes to this bug.