Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056520 - [RFE] Spice: exclude certain key combinations from being intercepted by virt-viewer and passed to VMs
Summary: [RFE] Spice: exclude certain key combinations from being intercepted by virt-...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.3.0
Hardware: All
OS: All
low
medium
Target Milestone: ---
: ---
Assignee: Martin Tessun
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks: 1057569
TreeView+ depends on / blocked
 
Reported: 2014-01-22 11:27 UTC by Evgheni Dereveanchin
Modified: 2018-07-03 07:55 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1057569 (view as bug list)
Environment:
Last Closed: 2018-07-03 07:55:19 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)

Description Evgheni Dereveanchin 2014-01-22 11:27:28 UTC
Description of problem:
virt-viewer intercepts all key combinations and passes them to the guest. This RFE requests implementation of a filter which would allow for a configurable ignore list of keys which need not to be intercepted and passed to the client OS used to run virt-viewer.

Version-Release number of selected component (if applicable):
spice-xpi-2.7.24.el6

Steps to Reproduce:
Windows 7 client running Virt-Viewer with a SPICE session to a RHEL VM . Pressing Win+L combination should not be passed to RHEL, but lock the Windows desktop instead. At the moment this scenario is not possible, use must first press Ctrl+F12 before pressing Win+L

Actual results:
key combination passed to the RHEL VM (and ignored there since not mapped to anything in RHEL)

Expected results:
Windows machine is locked

Additional info:
Having a configuration parameter setting the ignored combinations is required, since the exact keys may differ in different deployments.

Comment 3 Marc-Andre Lureau 2014-02-17 12:25:00 UTC
Are we simply talking specifically about client-side system keys, such as win+l, alt+tab etc? In this case, you can already use an environment variable to disable keyboard grab, you could try with set SPICE_NOGRAB=1 (although that will also affect mouse grabs, which is not an issue if you have client side mouse)

Comment 4 CongDong 2014-02-20 09:24:55 UTC
As the description and comment 1 said, I think it's a mingw-virt-viewer bug.

Comment 5 Tomas Jamrisko 2014-02-20 11:52:23 UTC
No, it's not. Both virt-viewer and mingw-virt-viewer need to have this fixed. I created a clone (BZ#1057569) of this bug for mingw-virt-viewer some time ago.

Comment 7 Evgheni Dereveanchin 2014-04-02 09:59:33 UTC
Marc-Andre, specific key combinations only need to be ignored, the rest must be forwarded to the VM. Unfortunately SPICE_NOGRAB=1 will not do the trick.

Comment 8 Marc-Andre Lureau 2014-04-02 11:23:25 UTC
(In reply to Evgheni Dereveanchin from comment #7)
> Marc-Andre, specific key combinations only need to be ignored, the rest must
> be forwarded to the VM. Unfortunately SPICE_NOGRAB=1 will not do the trick.

what specific key combinations? They are most likely going to be Window Manager or system keys, which should not be captured with SPICE_NOGRAB=1. Why it will not do the trick?

Comment 9 Evgheni Dereveanchin 2014-04-02 11:29:26 UTC
For example here's a use case scenario:

Win+L   -> not sent to the VDI
Alt+Tab -> sent to VDI

With SPICE_NOGRAB=1 Alt+Tab will be used on the client system and not sent to the VDI

Comment 10 Marc-Andre Lureau 2014-04-02 15:26:43 UTC
this is pretty tricky request, the low-level hook handler isn't easily configurable.


(In reply to Evgheni Dereveanchin from comment #9)
> For example here's a use case scenario:
> 
> Win+L   -> not sent to the VDI

Starting from vista/win7, win+l is always intercepted by client.

What version of windows are you using?

Comment 11 Evgheni Dereveanchin 2014-04-15 09:08:16 UTC
Windows 7 is used on client side. Besides Win+L most of Win+* need to be ignored, as well as some Alt+* key combinations.

Comment 12 Marc-Andre Lureau 2014-04-15 09:23:47 UTC
(In reply to Evgheni Dereveanchin from comment #11)
> Windows 7 is used on client side. Besides Win+L most of Win+* need to be
> ignored, as well as some Alt+* key combinations.

Why is win+l not catched by client side? Did you change some Windows configuration (disable lock screen)? Starting from vista/win7, win+l is always intercepted by client os.

Regarding the other keys, please specify which one and why.

From a user experience point of view, it seems better to me to allow usage of key combinations in guest and in client os. It is much clearer to have actions directed to guest when the pointer is on the guest, and to the client os when the pointer is outside. Mixing both feels very wrong to me, so I think we should really understand the use case first before jumping in tricky implementation.

Comment 13 Marc-Andre Lureau 2014-05-26 12:11:40 UTC
Evgheni, the bug is in needinfo for a while now.

With Windows client, the Win+L key is always intercepted by client OS.

Please provide a more detailed description of the bug/issue and use case (goal/situation: key combination, focus state, client and guest os version).

If this bug is a Windows client bug only, I propose to close this RHEL bug.

Comment 16 Marc-Andre Lureau 2014-06-25 13:05:06 UTC
moving out of 6.6

Comment 19 David Blechter 2014-06-25 14:29:01 UTC
for the RHEVM customers moving to the RFEs component for PM review and apporval

Comment 22 Michal Skrivanek 2014-06-30 08:54:24 UTC
(AFAICT this is still on SPICE side…)


Note You need to log in before you can comment on or make changes to this bug.