Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056518 - dist-geo-rep: geo-rep create no longer throws warning message when the slave has less available size than master
Summary: dist-geo-rep: geo-rep create no longer throws warning message when the slave ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: pre-release
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1026787
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 11:21 UTC by Aravinda VK
Modified: 2014-04-17 11:52 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1026787
Environment:
Last Closed: 2014-04-17 11:52:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-01-22 11:22:29 UTC
REVIEW: http://review.gluster.org/6746 (geo-rep: Fix no error when slave size less than master size) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2014-01-23 17:41:38 UTC
COMMIT: http://review.gluster.org/6746 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit a0fbd41d2b10829503df1826bf2c98dc347de739
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Jan 17 16:45:55 2014 +0530

    geo-rep: Fix no error when slave size less than master size
    
    in df command output, default block-size is 1K, but BUFFER_SIZE is
    in bytes, so verify will succeed even if slave size is less than
    master size.
    
    Added -B1 to df command(that is --block-size=1) to get all values in
    bytes.
    
    BUG: 1056518
    Change-Id: I2384d2a6f2505d967e0538b95fbf111c15b26f30
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/6746
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Anand Avati 2014-01-29 06:16:30 UTC
REVIEW: http://review.gluster.org/6846 (geo-rep: Fix no error when slave size less than master size) posted (#1) for review on release-3.5 by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2014-02-03 04:25:18 UTC
COMMIT: http://review.gluster.org/6846 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit 0f018e33ec8510ef0afc7daa9f12b7e21c8c03dc
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Jan 17 16:45:55 2014 +0530

    geo-rep: Fix no error when slave size less than master size
    
    in df command output, default block-size is 1K, but BUFFER_SIZE is
    in bytes, so verify will succeed even if slave size is less than
    master size.
    
    Added -B1 to df command(that is --block-size=1) to get all values in
    bytes.
    
    BUG: 1056518
    Change-Id: I21157a66b0500c954cb6ffb2a2cdf29163b3b269
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/6746
    Reviewed-on: http://review.gluster.org/6846
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2014-04-17 11:52:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.