Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056490 - REST client does not receive a response after start of a process on Oracle11gR2
Summary: REST client does not receive a response after start of a process on Oracle11gR2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER1
: 6.0.1
Assignee: Marco Rietveld
QA Contact: Ivo Bek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 09:58 UTC by Ivo Bek
Modified: 2016-09-20 05:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Oracle11gR2
Last Closed: 2014-08-06 20:03:53 UTC
Type: Bug


Attachments (Terms of Use)
server log (deleted)
2014-01-22 09:58 UTC, Ivo Bek
no flags Details
updated server log just for REST test (deleted)
2014-01-23 10:11 UTC, Ivo Bek
no flags Details

Description Ivo Bek 2014-01-22 09:58:34 UTC
Created attachment 853770 [details]
server log

Description of problem:

I have a simple process with a single script task. REST client will timeout, when it is waiting for a response since the start command was called. In the server log you can see that the process has been completed because there is a script task output "Hello World!!!", the first one. The second output in the middle of exceptions is for JMS call.

In the server log there is nothing interesting what could be a cause that the client does not receive the response for the start command call. Perhaps it will be a similar issue to BZ 1056488 where is the same problem but a different client/handler which is JMS.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Marco Rietveld 2014-01-22 15:37:57 UTC
Given that this runs on Jenkins, is it possible that this is caused by the server being overloaded and the response simply coming too late?

Comment 3 Ivo Bek 2014-01-23 10:11:28 UTC
Created attachment 854276 [details]
updated server log just for REST test

I attached the server log just for REST test.

Your point to late response let me to compare time of job running on PostgreSQL 9.2 and Oracle11gR2. There is a difference 1 minute between them, 2:46 versus 3:45. It could be caused by slower database or another problem. I also have to say that I use the security policy which causes slowdown too.

Comment 4 Ivo Bek 2014-01-23 13:15:31 UTC
I confirm that this problem happens only when the security policy is enabled. When I disable it, everything works as expected.

Comment 5 Marco Rietveld 2014-02-04 11:14:23 UTC
Ivo, 

Would you mind rerunning these tests on the CR2 release? In my own setup (local Oracle DB, 11.2.0.1.0), I haven't been able to reproduce the problem on CR2. 

Thanks!

Comment 6 Marco Rietveld 2014-02-04 14:36:53 UTC
Similar to 1056488, the problem her is caused by the timeout on the request being too small and the oracle db being not quick enough. 

I've added a way to increase the timeout on REST requests. 

Fixed. Commits: 

6.0.x: 
https://github.com/droolsjbpm/droolsjbpm-integration/commit/ecdeba81

master: 
https://github.com/droolsjbpm/droolsjbpm-integration/commit/590fe8f5

Comment 7 Lukáš Petrovický 2014-02-07 16:19:29 UTC
This no longer has a target release of 6.0.0.

Comment 8 Ivo Bek 2014-02-17 16:17:21 UTC
Verified in BPMS 6.0.1.ER1

Be aware that timeout for JMS factory has changed from miliseconds to seconds.


Note You need to log in before you can comment on or make changes to this bug.