Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056488 - JMS client does not receive a response after start of a process on Oracle11gR2
Summary: JMS client does not receive a response after start of a process on Oracle11gR2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 6.0.0
Assignee: Marco Rietveld
QA Contact: Ivo Bek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 09:57 UTC by Ivo Bek
Modified: 2016-09-20 05:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Oracle11gR2
Last Closed: 2014-02-04 13:10:10 UTC
Type: Bug


Attachments (Terms of Use)
server log (deleted)
2014-01-22 09:57 UTC, Ivo Bek
no flags Details
updated server log just for JMS test (deleted)
2014-01-23 09:28 UTC, Ivo Bek
no flags Details

Description Ivo Bek 2014-01-22 09:57:10 UTC
Created attachment 853769 [details]
server log

Description of problem:

I have a simple process with a single script task. JMS client will timeout, when it is waiting for a response since the start command was called. In the server log you can see that the process has been completed because there is a script task output "Hello World!!!" in the middle of exceptions. The first output is for REST call.

The main reason could be that it did not find queue/KIE.RESPONSE.ALL. "NameNotFoundException: queue/KIE.RESPONSE.ALL"

There is a question what is different to other databases when the same configuration works in the other environments. Why the queue cannot be found only when I use Oracle11gR2?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ivo Bek 2014-01-22 10:02:06 UTC
There is a similar BZ 1056490 where is the same issue (the client does not receive a response after start of a process on Oracle11gR2) but a different client/handler which is REST.

Comment 3 Kris Verlaenen 2014-01-22 17:42:00 UTC
@Ivo, please note that the execution of the JMS message only seems to happen at shutdown.  It seems the REST request is somehow blocked (even though the process instance executed, as seen in the server log output), and only when the server shutdown is started (at 04:33:38,951) the REST request now fails (with exception at 04:34:19,297), after which the JMS request is now able to continue.  But since the server is already shutting down, this will fail for various reasons.  Would it be possible to at least split this up in two different tests and provide the logs for each separately?

Comment 4 Kris Verlaenen 2014-01-22 17:55:11 UTC
It could also be that the REST request is not blocked, but the start of JMS request is.  Having two separate logs will help figuring this out.

Comment 5 Ivo Bek 2014-01-23 09:27:06 UTC
Kris, you are right that it happens after the server is shutting down. That is because the client will not get any response, the test will fail, and the server will get the request to shutdown. So, after all it is not surprising that the queue is not there any more because before it tries to respond, JMS is unbound:

04:11:56,807 INFO  [org.jboss.as.messaging] (ServerService Thread Pool -- 76) JBAS011605: Unbound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory

In the new server log just for JMS test case, data source is also unbound which produces another exceptions.

04:11:56,799 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-15) JBAS010409: Unbound data source [java:jboss/datasources/ExampleDS]

I see the main problem is that the client will not get the response though the message will arrive.

Comment 6 Ivo Bek 2014-01-23 09:28:16 UTC
Created attachment 854264 [details]
updated server log just for JMS test

Comment 7 Ivo Bek 2014-01-23 13:15:27 UTC
I confirm that this problem happens only when the security policy is enabled. When I disable it, everything works as expected.

Comment 8 Ivo Bek 2014-01-23 13:26:53 UTC
Please ignore the previous comment. It is valid only for REST client that the error appears only when the security policy is enabled.

Comment 10 Marco Rietveld 2014-02-04 11:15:07 UTC
Ivo, 

Would you mind rerunning these tests on the CR2 release? In my own setup (local Oracle DB, 11.2.0.1.0), I haven't been able to reproduce the problem on CR2. 

Thanks!

Comment 11 Marco Rietveld 2014-02-04 13:10:10 UTC
I've talked with Ivo and the problem has to do with the timeout (for the request) and the reactivity/load of the oracle database used. The Remote Java API provides a way to set the timeout. 

Because of this, Ivo and I have agreed to close this bug.


Note You need to log in before you can comment on or make changes to this bug.