Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056474 - FTBFS of byteman
Summary: FTBFS of byteman
Keywords:
Status: CLOSED DUPLICATE of bug 1029956
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: byteman
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Berk
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 09:38 UTC by Tuomo Soini
Modified: 2014-02-05 10:19 UTC (History)
5 users (show)

Fixed In Version: byteman-2.0.4-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 10:19:30 UTC


Attachments (Terms of Use)

Description Tuomo Soini 2014-01-22 09:38:15 UTC
byteman-2.0.4-3.el7 fail to build in mock with:

[ERROR] Reactor project org.jboss.byteman:byteman-install:jar:2.0.4 has system-scoped dependencies: [
  com.sun:tools::jar:1.6

Fix from fedora is:

diff --git a/byteman.spec b/byteman.spec
index fd6ecb7..de5b90e 100644
--- a/byteman.spec
+++ b/byteman.spec
@@ -67,6 +67,11 @@ This package contains the API documentation for %{name}.
 sed -i "s|net.sf.squirrel-sql.thirdparty-non-maven|java_cup|" agent/pom.xml
 sed -i "s|java-cup|java_cup|" agent/pom.xml
 
+# Remove tools.jar from dependencyManagement (Fedora-specific patch).
+# In Fedora tools.jar doesn't need to use system scope or provide
+# systemPath - Maven will find it anyways.
+%pom_remove_dep com.sun:tools
+
 %build
 %mvn_build

Comment 4 Martin Cermak 2014-02-05 10:19:30 UTC

*** This bug has been marked as a duplicate of bug 1029956 ***


Note You need to log in before you can comment on or make changes to this bug.