Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056400 - DNF not support url installation for a package
Summary: DNF not support url installation for a package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1049671 1058980 1060166 1070441 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 05:55 UTC by Praveen Kumar
Modified: 2014-02-27 12:58 UTC (History)
14 users (show)

Fixed In Version: dnf-0.4.13-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-09 03:54:40 UTC


Attachments (Terms of Use)

Description Praveen Kumar 2014-01-22 05:55:41 UTC
Description of problem:
DNF is not support url rpm installation as yum supports.

Version-Release number of selected component (if applicable):
dnf-0:0.4.11-1.fc20.noarch

How reproducible:
dnf install http://kojipkgs.fedoraproject.org//packages/python-flask-sqlalchemy/1.0/2.fc20/noarch/python-flask-sqlalchemy-1.0-2.fc20.noarch.rpm


Actual results:
Error: Nothing to do.

Expected results:
It's should fetch the rpm and install it after resolving the dependencies.

Comment 1 Ales Kozumplik 2014-01-22 06:06:32 UTC
Praveen, just to confirm, what does 'rpm -q python-flask-sqlalchemy' return?

Comment 2 Ales Kozumplik 2014-01-22 06:07:53 UTC
Maybe related to bug 1049671, Radek please take a look once the time permits.

Comment 3 Zdeněk Pavlas 2014-01-22 08:13:01 UTC
Fixes the bug for me..


commit 024f83a65a434efe8d669aa3de800e91ac6e9969
Author: Zdenek Pavlas <zpavlas@redhat.com>
Date:   Wed Jan 22 09:12:18 2014 +0100

    Installing a local pkg is okay. (RhBug#1056400)

diff --git a/dnf/cli/cli.py b/dnf/cli/cli.py
index 16ba6c2..5ca258c 100644
--- a/dnf/cli/cli.py
+++ b/dnf/cli/cli.py
@@ -322,6 +322,7 @@ class BaseCli(dnf.Base):
         for arg in userlist:
             if arg.endswith('.rpm'):
                 self.install_local(arg)
+                done = True
                 continue # it was something on disk and it ended in rpm
                          # no matter what we don't go looking at repos
             elif arg.startswith('@'):

Comment 4 Zdeněk Pavlas 2014-01-22 10:32:49 UTC
Reproduces even when pkg is not installed..

Comment 5 Praveen Kumar 2014-01-23 03:35:35 UTC
It's different from #1049671 ( which claims that local downloaded package not able to install) , In this bug if 'python-flask-sqlalchemy' don't present locally then it's suppose to download with give url and store in some tmp location as yum use to do and then install.

Comment 6 Ales Kozumplik 2014-01-24 08:44:32 UTC
moving this to Zdenek who's got a patch.

Comment 7 Ales Kozumplik 2014-01-24 08:49:25 UTC
*** Bug 1049671 has been marked as a duplicate of this bug. ***

Comment 8 Ales Kozumplik 2014-01-29 12:33:15 UTC
*** Bug 1058980 has been marked as a duplicate of this bug. ***

Comment 9 Zdeněk Pavlas 2014-01-29 13:37:08 UTC
The patch is merged upstream.

Comment 10 Ales Kozumplik 2014-01-31 12:13:46 UTC
*** Bug 1060166 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2014-02-07 06:44:07 UTC
dnf-0.4.13-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.13-2.fc20

Comment 13 Fedora Update System 2014-02-08 05:08:01 UTC
Package dnf-0.4.13-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.13-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2172/dnf-0.4.13-2.fc20
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2014-02-09 03:54:40 UTC
dnf-0.4.13-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Álvaro Castillo 2014-02-10 00:29:03 UTC
That's works. Solved.

Thank you!

Comment 16 Radek Holy 2014-02-27 12:58:22 UTC
*** Bug 1070441 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.