Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056375 - fdisk doesn't know about the Freedesktop $BOOT partition type
Summary: fdisk doesn't know about the Freedesktop $BOOT partition type
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 20
Hardware: Unspecified
OS: All
unspecified
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 04:29 UTC by Cristian Ciupitu
Modified: 2014-05-07 11:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-07 11:04:57 UTC


Attachments (Terms of Use)

Description Cristian Ciupitu 2014-01-22 04:29:34 UTC
Description of problem:
fdisk doesn't know about the Freedesktop $BOOT partition type.

Version-Release number of selected component (if applicable):
util-linux-2.24-2.fc20.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. fdisk /dev/sdc

Actual results:
/dev/sdc2        788480      2099199   640M unknown

Expected results:
"Freedesktop $BOOT" instead of "unknown"

Additional info:
gdisk output:

   2          788480         2099199   640.0 MiB   EA00  Freedesktop $BOOT

For more details see http://www.freedesktop.org/wiki/Specifications/BootLoaderSpec/

Comment 1 Cristian Ciupitu 2014-01-25 18:49:05 UTC
Thanks to explanations of Rod Smith[1], I realized that I'm comparing
apples to oranges and that the columns of fdisk and gdisk are different.
Nevertheless since "Freedesktop $BOOT" has its own GUID, it would still
be nice if fdisk would recognize it.

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=1056376#c4

Comment 2 Karel Zak 2014-05-07 11:04:57 UTC
I guess you mean the new root, /home, .. etc. GUIDs. It will be supported in the next util-linxu release (already in upstream master branch).


Note You need to log in before you can comment on or make changes to this bug.