Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056364 - postgrey.service has syntax error in recent update
Summary: postgrey.service has syntax error in recent update
Keywords:
Status: CLOSED DUPLICATE of bug 1055638
Alias: None
Product: Fedora
Classification: Fedora
Component: postgrey
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 04:08 UTC by Mark Mielke
Modified: 2014-01-23 03:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 03:40:59 UTC


Attachments (Terms of Use)

Description Mark Mielke 2014-01-22 04:08:45 UTC
Description of problem:

After recent update, probably 1.34-9, postgrey no longer starts.

In postgrey.service, it lists:

ExecStart=/usr/sbin/postgrey \
 --unix=/var/spool/postfix/postgrey/socket \
 --pidfile=/var/run/postgrey.pid \
 --group=postgrey \
 --user=postgrey \
 --greylist-text="Greylisted for %%s seconds"
 --daemonize \
 $POSTGREY_OPTS


The line starting with --greylist-text appears to be missing a "\" at the end of line. I added " \" manually and the problem appears to be fixed.

Version-Release number of selected component (if applicable):

1.34-10


How reproducible:

Visible on at least two machines now.

Comment 1 Christopher Meng 2014-01-23 03:40:59 UTC
Thanks for your report, my fault.

*** This bug has been marked as a duplicate of bug 1055638 ***


Note You need to log in before you can comment on or make changes to this bug.