Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056349 - Should update the mms agent monitor url
Summary: Should update the mms agent monitor url
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Dan McPherson
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 02:59 UTC by Meng Bo
Modified: 2015-05-15 00:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 19:09:52 UTC


Attachments (Terms of Use)

Description Meng Bo 2014-01-22 02:59:22 UTC
Description of problem:
Add mongodb and 10gen-mms-agent to a non-scale app, it will print the mms moniter url as "https://mms.10gen.com/". But it will be redirected to "https://mms.mongodb.com/".

It is better to update the url to latest one in case the redirecting does not work.

Version-Release number of selected component (if applicable):
devenv_4255

How reproducible:
always

Steps to Reproduce:
1. Create app with mongodb added
2. Add settings.py which get from your mms account
3. Add the 10gen-mms-agent cartridge

Actual results:
The url of the mms agent is out of date.

Adding 10gen-mms-agent-0.1 to application 'myworld' ... done

10gen-mms-agent-0.1 (10gen Mongo Monitoring Service Agent)
----------------------------------------------------------
  Gears:          Located with php-5.3, mongodb-2.2, mysql-5.1
  Monitoring URL: https://mms.10gen.com/

10gen-mms-agent added. 
Please configure your mongodb host at https://mms.10gen.com/ to start monitoring performance data.

Monitoring URL: https://mms.10gen.com/


Expected results:
Should use the new url https://mms.mongodb.com/

Additional info:
Maybe we also need to update the cartridge name since the 10gen history on wikipedia:

On August 27, 2013, 10gen announced that it would change its name to MongoDB Inc., closer aligning itself with what ultimately became its flagship products.

Comment 1 Dan McPherson 2014-01-22 14:24:42 UTC
https://github.com/openshift/origin-server/pull/4552

Comment 3 chunchen 2014-01-23 02:56:47 UTC
It's fixed, verified on devenv_4261, please refer to the following results:

1. Create app with mongodb added
2. Add settings.py which get from your mms account
3. Add the 10gen-mms-agent cartridge

$ rhc cartridge add 10gen-mms-agent-0.1 -a crb19
Adding 10gen-mms-agent-0.1 to application 'crb19' ... done

10gen-mms-agent-0.1 (10gen Mongo Monitoring Service Agent)
----------------------------------------------------------
  Gears:          Located with ruby-1.9, mysql-5.1, mongodb-2.2
  Monitoring URL: https://mms.mongodb.com/

10gen-mms-agent added. 
Please configure your mongodb host at https://mms.mongodb.com/ to start monitoring performance data.

Monitoring URL: https://mms.mongodb.com/


Note You need to log in before you can comment on or make changes to this bug.