Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056342 - Disk partitioning errors if /boot on lvmlv
Summary: Disk partitioning errors if /boot on lvmlv
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 02:06 UTC by Ian Mortimer
Modified: 2014-01-22 15:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-22 15:32:19 UTC


Attachments (Terms of Use)

Description Ian Mortimer 2014-01-22 02:06:40 UTC
Description of problem:
Configuring custom partitioning on an existing F18 system with / on an lvmlv gets the error:

/boot filesystem cannot be of type lvmlv 


Version-Release number of selected component (if applicable):
anaconda-20.25.15-1.fc20

How reproducible:
Always


Steps to Reproduce:
1. Partition a system with / on an lvm and no separate /boot
2. Start on installation of Fedora 20
3. Select custom partitioning and use existing partitions

Actual results:
The installer reports:  Error checking storage configuration
On expansion it shows the error:  /boot filesystem cannot be of type lvmlv


Expected results:
The installation should proceed since it's a valid configuration.


Additional info:
This system was installed with Fedora 18 which did not complain about /boot on lvmlv.  I was able to install Fedora 20 using kickstart with the identical configuration which shows the configuration is valid.


Thanks
--
Ian

Comment 1 Martin Kolman 2014-01-22 10:33:00 UTC
We have disabled support for having boot on lvmlv as of Fedora 20 due to the serious issues the tools we use for bootloader setup have with using an lvmlv for boot. 

I believe Dave Lehman can provide a more detailed answer, so I'm adding him to CC.

Comment 2 David Lehman 2014-01-22 15:32:19 UTC
/boot on lvm and btrfs have both been disabled due to issues with bootloader tools. What was allowed in the past is irrelevant. Sorry for the inconvenience.


Note You need to log in before you can comment on or make changes to this bug.