Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056323 - Ping command hides invalid username/password
Summary: Ping command hides invalid username/password
Keywords:
Status: CLOSED DUPLICATE of bug 1102521
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Adam Price
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 01:00 UTC by Bryan Kearney
Modified: 2016-04-22 15:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-04 03:10:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4947 None None None 2016-04-22 15:59:47 UTC

Description Bryan Kearney 2014-01-22 01:00:39 UTC
Calling hammer ping with an invalid username/password combo gives an odd error which looks like an NPE:

pulp_auth:   
  Status:    FAIL
  Duration:  
  Message:   undefined method `resources' for nil:NilClass


This is due to auth failures. Other commands with invalis username/password return this:

[bkearney@bkearney hammer-cli]$ bundle exec ./bin/hammer -u adminaasdada -p changeme organization create --name fred
Could not create the organization:
  Invalid username or password
[bkearney@bkearney hammer-cli]$

Comment 3 Mike McCune 2014-06-04 03:10:27 UTC
this is just BZ 1102521

ping doesn't authenticate so you get that message no matter what uname you use.

*** This bug has been marked as a duplicate of bug 1102521 ***


Note You need to log in before you can comment on or make changes to this bug.