Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056298 - HDMI screen resolution mis-detected and impossible to fix
Summary: HDMI screen resolution mis-detected and impossible to fix
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 22:50 UTC by Travis Reitter
Modified: 2015-06-29 14:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 14:38:30 UTC


Attachments (Terms of Use)
Mis-detected screen resolution (deleted)
2014-01-21 22:50 UTC, Travis Reitter
no flags Details

Description Travis Reitter 2014-01-21 22:50:20 UTC
Created attachment 853490 [details]
Mis-detected screen resolution

(Gnome Shell may not be the best component but this issue definitely touches a few Gnome components; please change as necessary)

Description of problem:

If I boot my Samsung 9 series laptop with the lid closed and my Samsung SyncMaster P2770 external screen connected over HDMI, Gnome mis-detects the screen's physical size and scales widgets and fonts insanely high. See screenshot (and realize that it's being displayed on a regular desktop screen).

The Displays control panel lists my external screen as being 7" even though it's actually 27" (hence the incorrect resolution scaling).

So, the core problem should be fixed but it's compounded by the fact that the Displays control panel doesn't give me an option to change the resolution. I can't find any way to fix it other than rebooting with my laptop lid open.

It's also a little weird that Gnome Shell scales for the supposed physical resolution but the login manager doesn't. If my screen actually were 7" at a really high resolution, the login manager would be unusably-small.

Version-Release number of selected component (if applicable):

Fedora 20

How reproducible: 100%

Comment 1 birger 2014-03-19 10:07:10 UTC
I have a very similar issue.
My hardware is the new/second generation Lenovo X1 with a built in screen that gets detected as 14" 16:9 2560x1440.

When using only the internal screen Gnome applications look 'normal'. Google Chrome looks almost like the 'thumbnail' images in the gnome shell 'Activities' view. Firefox has 'normal' framing with menus, etc. But the actual web page is 'thumbnailed' just like chrome.

then I connected my external DP-connected screen, a 29" 21:9 2560x1080 screen... And on that screen everything gets scaled up. Suddenly chrome is the only normal-looking application. The content in firefox is also ok, while everything around the content is way too big. The gnome screen configuration tool actually fills the whole 29" screen!

I have used the same setup on the old X1 and a Lenovo X230. Both worked fine with the exact same screen, although it is now connected through a new docking station. The big difference seems to be the high resolution built-in screen on the new laptop.

Comment 2 birger 2014-03-20 10:05:45 UTC
I tried the Gnome 3.12 test build documented at http://copr.fedoraproject.org/coprs/rhughes/f20-gnome-3-12/

The inconsistent scalings are gone. Both gnome and firefox now look normal again. I am running with my external (normal dpi) monitor as primary (the one with the menus), and everything is back to normal scaling on this monitor. On the laptop monitor everything is very, very small. I assume this is because X doesn't handle per monitor dpi. Hopefully wayland will bring a fix for mixed-dpi environments. Or I have to get a high-dpi desktop monitor. :-) Sadly, 3.12 gnome-shell crashes whenever I try to switch primary screen, but it looks like it is actuallty trying to switch scaling when I do that. Perhaps scaling will always be correct on the primary screen?

Comment 3 Fedora End Of Life 2015-05-29 10:36:39 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Alex Hopcroft 2015-05-29 13:03:51 UTC
I can still see this bug in fedora 21 and 22. I'm not sure if it's actively being progressed though as the last update was 2014.

To me this problem exists exactly as originally described.

Can the package maintainer please update the version to either 21 or 22.

Comment 5 birger 2015-05-29 13:25:46 UTC
From what i have found by discussing this with people with far more knowledge about these matters than me the problem won't be easily fixed with x11 as the undelying engine. X doesn't really handle DPI (dots per inch) per screen, the "main" screen seems to set the x servers notion of DPI across all screens.

Wayland is able to handle this better at the lower levels, but at least back in 2014 this wasn't exposed in libraries yet. Thus the user interface was still unable to get at the info.

The bug should be promoted to f22, and perhaps spread over several components. Gnome shell can't be fixed until it can get at the info. That may only happen on wayland. Where should this be implemented?

Comment 6 Fedora End Of Life 2015-06-29 14:38:30 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.