Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056293 - May we have a gnome-contacts in EPEL?
Summary: May we have a gnome-contacts in EPEL?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-contacts
Version: 21
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 22:19 UTC by Todd
Modified: 2015-10-06 19:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-06 02:32:42 UTC


Attachments (Terms of Use)

Description Todd 2014-01-21 22:19:47 UTC
May we have a 64 bit spin of gnome contacts for EPEL (RHEL 6.x, Scientific Linux 6.x)?  There is a SRPM for Fedora Core 19, but it won't recompile


# cat /etc/redhat-release
Scientific Linux release 6.4 (Carbon)

# rpmbuild --rebuild gnome-contacts-3.8.2-2.fc19.src.rpm
Installing gnome-contacts-3.8.2-2.fc19.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
        folks-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64
        gtk3-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64
        vala-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64
        libnotify-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64
        gnome-desktop3-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64
        cheese-libs-devel is needed by gnome-contacts-3.8.2-2.el6.x86_64


# yum install folks-devel gtk3-devel vala-devel libnotify-devel gnome-desktop3-devel cheese-libs-devel
Loaded plugins: priorities, refresh-packagekit, security
48 packages excluded due to repository priority protections
Setting up Install Process
No package folks-devel available.
No package gtk3-devel available.
No package vala-devel available.
No package gnome-desktop3-devel available.
No package cheese-libs-devel available.
Resolving Dependencies
--> Running transaction check
---> Package libnotify-devel.x86_64 0:0.5.0-1.el6 will be installed

Comment 1 Fedora End Of Life 2015-01-09 21:07:57 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 David King 2015-10-06 02:32:42 UTC
RHEL 6 (or a derivative) is too old to support gnome-contacts (of any version). The biggest problem is the lack of dependencies (such as gtk3), but all the other dependencies are likely too old. RHEL 7 includes gnome-contacts (and roughly corresponds to Fedora 18/19), so the best way to get gnome-contacts on RHEL is to upgrade.

Comment 3 Todd 2015-10-06 19:21:00 UTC
Hi,

I finally did upgrade to 7.1 a month ago.  What a nightmare, especially with the dropping of 32 bit support (wine32 was a bugger to figure out).  I think I finally have everything back to normal now.

Thank you for the response.


Note You need to log in before you can comment on or make changes to this bug.