Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1056264 - Many "has not been configured as an alternative for" messages on upgrade
Summary: Many "has not been configured as an alternative for" messages on upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk
Version: 20
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1057411 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 19:37 UTC by Orion Poplawski
Modified: 2014-10-12 06:02 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-12 07:48:43 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2014-01-21 19:37:16 UTC
Description of problem:

/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/bin/javac has not been configured as an alternative for javac
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64 has not been configured as an alternative for java_sdk_openjdk
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64 has not been configured as an alternative for java_sdk_1.7.0
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/jre/bin/java has not been configured as an alternative for java
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/jre has not been configured as an alternative for jre_openjdk
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64/jre has not been configured as an alternative for jre_1.7.0
/usr/lib/jvm/jre-1.7.0-openjdk-1.7.0.60-2.4.4.0.fc20.x86_64 has not been configured as an alternative for jre_1.7.0_openjdk

This is caused by the following:

#we need to remove old alternatives with "_" typo //should live to f21:(
  ID="/usr/lib/jvm/\(\(jre\)\|\(java\)\)-1.7.0-openjdk"
  COMMAND=jre_1.7.0_openjdk
  for alt in $(alternatives --display $COMMAND | grep priority | awk '{print $1}'); do
    echo $alt | grep -q "$ID"
    if [ $? -eq 0 ]; then
      alternatives --remove $COMMAND $alt >& /dev/null || :
     fi
  done

This actually ends up removing the existing current link twice - first on install of the new package and second on removal of the old package, where it then complains.

I suspect you wanted a "_" somewhere in ID?

Version-Release number of selected component (if applicable):
java-1.7.0-openjdk-1.7.0.60-2.4.4.1.fc20.x86_64

How reproducible:
every time

Steps to Reproduce:
1. Updgrade or downgrade java-1.7.0-openjdk-headless

Comment 1 jiri vanek 2014-01-23 07:21:01 UTC
yes. this is known issue. I'm goig to remove this very soon.

Comment 2 jiri vanek 2014-01-24 13:32:49 UTC
*** Bug 1057411 has been marked as a duplicate of this bug. ***

Comment 3 Robin Laing 2014-10-12 05:56:51 UTC
Still in F20 as of tonight.

RPM Scriptlet: /usr/share/javadoc/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19/api has not been configured as an alternative for javadocdir
23:49:41 : RPM Scriptlet: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64/bin/javac has not been configured as an alternative for javac
23:49:41 : YUM: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64 has not been configured as an alternative for java_sdk_openjdk
23:49:41 : YUM: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64 has not been configured as an alternative for java_sdk_1.7.0
23:49:43 : RPM Scriptlet: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64/jre/bin/java has not been configured as an alternative for java
23:49:43 : YUM: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64/jre has not been configured as an alternative for jre_openjdk
23:49:43 : YUM: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64/jre has not been configured as an alternative for jre_1.7.0
23:49:43 : YUM: /usr/lib/jvm/jre-1.7.0-openjdk-1.7.0.65-2.5.1.2.fc19.x86_64 has not been configured as an alternative for jre_1.7.0_openjdk

Comment 4 Robin Laing 2014-10-12 06:02:09 UTC
Oops, I just noticed that I am on the F19 machine but it occurred on this machine.


Note You need to log in before you can comment on or make changes to this bug.